Go Down

Topic: [solved] Using Arduino Uno v3.0 with AVRDude manually (Read 665 times) previous topic - next topic


Nov 11, 2014, 04:25 pm Last Edit: Nov 19, 2014, 09:28 pm by lukaswiese
Hello Arduino community!

Yesterday I tried to get my Arduino run with an Editor, compiler and AVRDude instead of the standard IDE.
The compiling went fine but when I was trying to program the chip itself via AVRDude I got an error message regardless of doing it with the makefile or via an extra command in the Ubuntu Terminal. When I have done it with the arduino IDE everything went fine.

The command I have found, changed and after all used was this:

Code: [Select]
avrdude -F -V -c arduino -p ATMEGA328P -P /dev/ttyUSB0 -b 115200 -U flash:w:main.hex

i have checked the port via  is the IDE but I don't know if the baud rate was set right and at which value it should be set.

the error message was:
Code: [Select]
avrdude: stk500_recv(): programmer is not responding

avrdude done.  Thank you.

I've already searched the web alot to find a solution but I could not find out what the solution is.
Hopefully someone of you could help me.

Go Up