Go Down

Topic: OSX Yosemite does not recognize my Leonardo (Read 2843 times) previous topic - next topic

Skully

Hi,
I'm a new user/poster so please go easy on me.  I purchased a Conceptinetics DMX board (this one) which should show up as a Leonardo.  When I use an older machine it shows up fine in 10.0.6's Serial Port menu.  When I use on my 2014 15" MBP retina running 10.10 it does not show up at all in the Serial Port menu.

I've tried all of the suggestions here (at least to my knowledge) - terminal commands, using the FtdiDriverControl.app to disable the FTDI driver to no avail.  I really need to use this newer Mac for this stuff but just can't figure out how to get it to show up in the serial port menu.   I notice that it does show in  the System Report - USB as a generic "Communications Device". 

Any help would be appreciated!

spicetraders

Quote
Several posts on the MAC has been posted and answered on here.
I will make the assumption your running Yosemite and using IDE 1.5.8.

For most part three things seem to fix most.
 On Yosemite:
    1. install any port drivers needed.
    2. run this:
    ====sudo nvram boot-args="kext-dev-mode=1"====
    3. Restart MAC

Note run this means open a terminal on your MAC and enter the complete line between the ====

Install of virtual port drivers helps and works with most board types.
http://www.ftdichip.com/Drivers/VCP.htm


I take it by saying you have tried all on here you are referring to the above?

Skully

Thanks for the reply spicetraders.  I did try these steps to no avail.  I will try them again when I get back to the project tonight.  Otherwise, are their any other suggestions you are aware of?

Similarly I've had issues getting a Enttex DMX-USB light controller to work on the Yosemite Mac as well.  Must be an issue with the FTDI virtual driver.  Looking at their website, I installed the x64(64-bit) driver.  Perhaps I should try the 32-bit version?

spicetraders

I have three MACs all running 10.10 (and as of last night 10.10.1) with good connecting on various board (true Arduino and clones), I am still a few weeks from stepping to a 2014 retina still on late 2013 model.  But USB ports as far as known are still USB 3.0 standard with 2.0 support.   I think the 2.2.18 drives are same download for all 32 and 64 MACs.  
Out of curiosity do you use a bluetooth mouse and keyboard or a wired one?



Skully

I use the Apple Magic mouse at home (where my Arduino project is).  At work a different story, I plug Thunderbolt into an Elgato TB Dock plugged into an Apple Cinema display where I have a Logitech wireless dongle for a wireless mouse/keyboard combo.  Do you think it is affecting this setup?   I'll try connecting again once I get home in a couple hours.

spicetraders

Not likely but again never hurts.
I was looking if you had a wired keyboard, then it should have had a USB port on it.  So could be used to act as a buffer.

Skully

Son of a gun.  After about an hour of trying different things (remove all the FTDI drivers, reinstall, different cables), I got it to work after reading your post. :smiley-eek-blue:

I do have an Apple keyboard (for an older MacMini at home) and as soon as I hooked that up to my MBPr, the Arduino showed up correctly!   Thanks for the suggestion and help!

Go Up