Go Down

Topic: Flashing hiduino onto a Mega help (Read 1 time) previous topic - next topic

cao2284

I'm looking into flashing my arduino mega rev 3 (not a clone) with the hiduino firmware to bypass all that serial to midi software thats creating a problem.I found this page:

https://github.com/ddiakopoulos/hiduino/tree/master/Compiled%20Firmwares

And would think its the 'usbserial_mega_16u2.hex' file. Have no clue to check which one it is on the board.

What are the pro's and con's of flashing hiduino onto my board? Any tutorials on flashing so i dont turn it into a brick?What about flashing it back? Where can i find updated firmware for the stock arduino?
Any help would be great.thanks

DrAzzy

You see which one your board has by reading the markings on the smaller atmel chip, which is either an 16u2 or 8u2. If it's an FTDI or CH340G, your board is not official.

You might do better asking the Hiduino people the hiduino specific questions. I just read the documentation on hiduino, and I still cant figure out what the hell it is for!

The majority of us use the stock bootloader, and leave the 16u2 with stock firmware, and unless there's a reason you need hiduino, I'd suggest you do the same.
ATTinyCore for x4/x5/x61/x7/x8/x41/1634/828/x313 megaTinyCore for the megaavr ATtinies - Board Manager:
http://drazzy.com/package_drazzy.com_index.json
ATtiny breakouts, mosfets, awesome prototyping board in my store http://tindie.com/stores/DrAzzy

cao2284

I purchased it from the amazon store through 'NKC Electronics' which says they sell only real arduino boards...I ran into a bigger problem though.I tried it on windows...didnt work.Tried on ubuntu which involved erasing the boot loader then flashing the new hiduino image.(erasing boot loader worked/flashing new image didnt) Sooo i got a brick :( Wont show up in device manager besides (unknown device)

No drivers will install...nothing.I have no clue how to fix it,besides maybe trying to flash the original boot loader in ubuntu. The hiduino firmware basically turns it into a midi controller. No more serial to midi software or none of that stuff.Gonna see if i can even fix this thing.

cao2284

tried to install the bootloader/firmware back on but always get the same problem:

root@linux1:/home/linux/Desktop# sudo dfu-programmer atmega16u2 flash '/home/linux/Desktop/Arduino-COMBINED-dfu-usbserial-atmega16u2-Mega2560-Rev3.hex' --suppress-bootloader-mem
Error reading line 1.

root@linux1:/home/linux/Desktop# sudo dfu-programmer atmega16u2 flash '/home/linux/Desktop/Arduino-usbserial-atmega16u2-Mega2560-Rev3.hex'
Error reading line 1.

That 'Error reading line 1' i have no clue whats going on, or what im doing for that matter.Tried to put it in DFU mode and says regardless:

Bus 002 Device 006: ID 03eb:2fef Atmel Corp. 

My guess i either permanently fried it or idk.Any help please? thanks

cao2284

So now i know i pretty much semi-bricked it. Has anyone had experience using the USBtinyISP-v3.0? Its like $11.00 on ebay and found a tutorial to install it. Sounds like this will work:

http://projectsfromtech.blogspot.com/2013/03/burn-bootloader-to-arduino-mega-2560.html

Until then it goes back in the box i guess.

Go Up