Go Down

Topic: Arduino nightly not running (Read 6867 times) previous topic - next topic

nickobrien

Nov 24, 2014, 12:14 am Last Edit: Nov 24, 2014, 12:59 am by nickobrien
I'm having trouble installing the nightly version of the Arduino software for windows.  I'm running windows 10 tech preview.  The regular version of the Arduino software runs fine but when I download and extract the nightly version I run into a few errors. Firstly when I run the arduino.exe program a java virtual machine window pops open and says "a java exception has occurred" and when I run the debugger as a .txt file at the end of it, it says
"http://java.sun.com/javase/downloads/   An error occurred while starting the application.   This application was configured to use a bundled Java Runtime Environment but the runtime is missing or corrupted.  This application requires at least Java Development Kit The registry refers to a nonexistent Java Development Kit  installation or the runtime is corrupted."
When I run the debugger as a .exe and I keep the window open it says (attachment) 



Any help would be appreciated



sabrown

I get the same issue.  I'm trying to get a version of the IDE for windows that has the compile dependency fix - i.e. it won't compile every single file every time - I understand that for Windows only the nightly build has this...  any help appreciated.

Thanks

Simon

nickobrien

I think the problem lies within the installer because the download comes with JDK 7 and I have JDK 8

sabrown

Does the nightly build come with an installer?  I just get a zip file with the contents of the arduino folder...

So if I install Java 8 over the java folder in the arduino folder will that work?  Looks like it's complaining about a missing class from pde.jar (?)


nickobrien

I don't know but this problem still isn't fixed

nickobrien

I wonder if I download and install JDK 7 if it will work...

miguelfg2000

That is something common on Nightly or test versions of the Integrated Development Environment. You can still use the original version, but I would rather recommend you to send feedback to the Arduino team so that they can fix the issue.

I have a question: if you install the stable version of the IDE, are there any problems?

Please answer so that I can solve your issue.

Thanks, an Arduino fan

sabrown

As I understand it, in the latest stable build there is a bug in the windows version that means that on compile every single source file (including all libraries) gets compiled even if nothing has changed.  This means compile times can run into minutes.  This happens even when the IDE is installed in a folder that has no spaces in the pathname (which was a previous bug that had been fixed).  The issue has been resolved in the nightly build but that doesn't not seem to install under windows.

So as far as I can tell, right now anyone using the IDE under windows will have this lengthy compile time problem which is a reasonably major issue.  Is that right?

sabrown

Just downloaded nightly again and it now looks like it's working... and the compile problem is fixed. :)

Go Up