Go Down

Topic: No TCP/IP link,without pressing the reset button (Read 42045 times) previous topic - next topic


The 100nF capacitor between GND and reset works for me, setting the gateway and subnet doesn't......


Apr 16, 2010, 05:48 pm Last Edit: Apr 16, 2010, 05:49 pm by burni83 Reason: 1
I've always had a gateway and subnet set during my tests. Therefore I hardly believe that SaSaa's solution solved the reset problems in each case.



1. don't connect the reset pin of ethernet shield to the arduino (bend it a little bit away)
2. connect the reset pin of ethernet shield to a digital pin of the arduino

thanks, your solution works very well.
I use your code also to reset Ethernet shield if it hangs (quite often).

As far as you know, that's a problem related to Wiznet 5100 chipset?


HI all,
have you seen this:

New Ethernet Shield:
We're very happy to announce an updated version of the Arduino Ethernet shield, with some nice new features. This revision incorporates a micro-SD card slot so you can store files to send over the network. It's compatible with the Arduino Mega (using the SPI pins on the ICSP header). It adds a reset controller which should address the problems some people have had getting it to work directly on power-up. All-in-all, we think it's a well-rounded upgrade to a useful product.

It seems that the reset issue is addressed - even if i've not tried this new shield yet.
Any feedback?



In my tests, the reset controller on the revised shields seems to fix these problems.  Please let me know if it works for you.


I am new to the Arduino and can report I have not had any reset issues using the Rev5 EtherShield on a Arduino Mega. It has been plug and play hardware. I am having some connection refused with the library code with connect which brought me to this thread. It's intermittent failure at 1 per 300 or so connections and it fails with connection refused 6100 error code.


Nov 08, 2010, 06:21 pm Last Edit: Nov 08, 2010, 06:22 pm by Mavromatis Reason: 1
I've created my own ethernet shield board using the WIZNET W5100 and reference designs.  Everything works great, however, I just plugged the shield into a Gigbit switch and it fails to start.  When I plug it back into a 10/100 it works fine.  Any ideas?  It should just operate at 10/100, or is the gig-switch having issues?

Go Up