Go Down

Topic: New guy unable to upload (Read 655 times) previous topic - next topic

DrRobotNick

Hello Arduino community,
I'm new to the world of Arduino and I can't seem to get my very first project to upload to my UNO board. I'm running OS X Yosemite and I've tried pretty much everything on the official troubleshooting page. However,  still keep getting the same error message:

avrdude: stk500_recv(): programmer is not responding

I've tried burning the bootloader, but my computer just will not talk to the board! And yes, I have the correct board selected in the Tools menu. However, my L LED is blinking when I give the board power, and the "On" LED is on too. When I try to do any uploads, I get a momentary flash of two green LEDs before the entire upload fails.

If you have any suggestions, please let me know. I'm really ready to get started on some cool projects.

ChilliTronix

Start by posting a link to where you bought the board from for a start, that way we can tell what USB to serial converter is on the board.

Budvar10

@dl9sec
Quote
A lot of people seems to have a "programmer not responding problem", but no one of the guys which programmed the IDE seems to be interested to dig into the problem...
There in nothing for digging, I think. Simply there is no connection to MCU or no bootloader in MCU. IDE has nothing with this problem. Avrdude tool is called from IDE and this tool produce well known message:
avrdude: stk500_getsync(): not in sync: resp=0x00
if you thought this. No response from device.

@DrRobotNick
avrdude: stk500_recv(): programmer is not responding - no programmer connected to referred port probably
Provide more detailed info about your board first as ChilliTronix mentioned.
Arduino clone with ATmega1284P   http://forum.arduino.cc/index.php?topic=277260.0

Go Up