Go Down

Topic: problema con display led lcd1602iic  (Read 7531 times) previous topic - next topic

marinaio67

in che senso il gnd in comune?
 
hai collegato il gnd dell'alimentatore esterno con il gnd di arduino?

brunello22

ma che modello di scheda Arduino hai ?

fionda08

nono il gnd non è in comune allora, comunque arduino Uno R3
Fionda08

marinaio67

nono il gnd non è in comune allora, comunque arduino Uno R3
Ce la fai a metterlo in comune? Perchè comincio a dubitare che tu ascolti anche un solo suggerimento che ti viene dato...

fionda08

se non ascolto i suggerimenti che scrivo a fare?
Fionda08

fionda08

Si comunque, lho collegato ma niente addirittura nemmeno accende il display
Fionda08

marinaio67

se non ascolto i suggerimenti che scrivo a fare?
E' una settimana che chiedi aiuto ma: non fornisci lo schema che usi, non fornisci una foto dell'insieme (per averne una del lcd te l'ho dovuta chiedere e si vede appunto solo lcd), hai usato una marea di codici e ad ora non si sa quale stai usando, prima di postare la foto del solo lcd hai dato un link di un lcd diverso, il gnd in comune te l'avevano già detto, la scansione I2C pure... devo continuare?

fionda08

#37
Jan 04, 2015, 08:24 pm Last Edit: Jan 04, 2015, 08:25 pm by fionda08
Uso il codice che hai postato tu! Lo schema è questo
Il link è quello dove ho comprato l'oggetto, rivelatosi differente da quello acquistato, ma me ne sono accorto dopo.
Inoltre ho mandato un email al venditore e mi ha detto di cambiare indirizzo , provando 0x3F
Fionda08

testato

Sembra proprio il modulo della mia libreria in firma,
USA quella, sono inclusi gli esempi, almeno abbiamo una certezza sul SW.
Comunque se non ti risponde l'indirizzo i2c c'è poco da fare
- [Guida] IDE - http://goo.gl/ln6glr
- [Lib] ST7032i LCD I2C - http://goo.gl/GNojT6
- [Lib] PCF8574+HD44780 LCD I2C - http://goo.gl/r7CstH

fionda08

Buongiorno a tutti, allora ho provveduto a comprare un altro modulo display con i2c , e in effetti era davvero difettoso il mio.
Però ho notato che utilizzando un alimentazione esterna il modulo non funzionava, allora ho dovuto collegare tramite bradboard l'alimentazione e la massa di arduino. FUNZIONA
Grazie a tutti per il supporto.
Fionda08

cyberhs

Quote
Però ho notato che utilizzando un alimentazione esterna il modulo non funzionava
Probabilmente hai dimenticato di collegare tra loro le masse.

Go Up