Go Down

Topic: Disturbi Segnali ricevente 2,4ghz con radiocomando spento (Read 933 times) previous topic - next topic

filos

Ciao a tutti avrei bisogno di un aiuto per capire cosa fare . Vi spiego il problema , sto leggendo con arduino uno due segnali da 2 canali di una ricevente 2,4 ghz , quando il radiocomando e' acceso tutto a posto muovendo i 2 stick del radiocomando i valori letti con il comando pulsein seguono perfettamente, quando però spengo il radiocomando un canale mi da un segnale come se fosse uno stick tutto avanti.Visto che i segnali sono collegati direttamente agli ingressi arduino mi chiedevo se fosse possibile eliminare il disturbo inserendo una resistenza verso massa oppure dite i voi cosa potrei fare.grazie

PaoloP

Se è una caratteristica della ricevente puoi sfruttarla impostando un timeout per indicare all'Arduino che il radiocomando è spento.
Dovresti controllare il manuale della ricevente. Potrebbe essere anche un sistema di allerta per la perdita del segnale dal trasmettitore.
Hai monitorato anche gli altri canali o ne hai solo 2?

astrobeed

quando però spengo il radiocomando un canale mi da un segnale come se fosse uno stick tutto avanti.
E' normale, è il failsafe del radiocomando che interviene in caso di perdita del segnale Tx, devi leggere il manuale della tua radio per sapere come disattivarlo o settarlo, se possibile, in un punto predeterminato.
Scientia potentia est

filos

Grazie per le risposte proverò tutti i suggerimenti e vi aggiornerò.

filos

Bene,si trattava del failsafe ,purtroppo la mia radio ricevente economica nei manuali non spiegava nulla di tutto ciò è quindi neanche come escluderlo.Sono riuscito comunque nel mio intento cambiando i trim in modo che il segnale del failsafe fosse più basso del range dello stick in modo da poterlo discriminare col software in modo che si fermi tutto se il radiocomando fosse spento visto che il mezzo non vola ma va con cingoli. Grazie ancora dei suggerimenti.

Go Up