Go Down

Topic: Make:it Robotics Starter Kit trouble (Read 7388 times) previous topic - next topic

Ilyana

Hi,

So my friend and I recently got the Make:it Robotics Starter Kit, and we put together the walking version; we're pretty sure everything is put together right, and the code uploaded to the Uno with no errors, but it isn't working. The motor on one side turns continually (It's supposed to alternate with the other side) and the one on the other side never activates at all. We tested that motor in the spots for the one that works, and the motor itself is working fine.

Theoretically the tape on the legs going past the light sensors is supposed to tell the motors when to start and stop, and we noticed that the way the legs are set up it never really goes in front of the sensor on the one that works. On the other hand, changing the placement of the sensor so that it does didn't make any difference.

The code we're using is here: http://blog.radioshack.com/2014/05/radioshack-make-magazine-launch-make-robotics/

I'm curious if anyone has had the same problems, or knows anything we might have missed. Thanks!

Cactusface

Hi Ilyana,
                 I would imagine that not many of use know anything about this kit!! So I think you may need to give us a lot more info.

We need a schematic and code..  a bit more info on these sensors, etc.

Regards

Mel.
Open your mind! But not too far, your brains might fall out.
Also like Photography, model building and my 300+ Cacti and Succs.

Ilyana

Hi,

That's completely understandable. I was mostly hoping that someone would have happened to have tried it and run into the same issues.

Unfortunately, all I can really give you is the design shown here: http://demandware.edgesuite.net/aasr_prd/on/demandware.static/Sites-radioshack-Site/Sites-radioshack-Library/default/v1416222026366/Support/ProductManuals/2770168_PM_EN.pdf

And the code here: http://blog.radioshack.com/wp-content/uploads/2014/05/Make-it-Robotics-Starter-Kit-Support-Files.zip

It's probably also worth noting that the kit did seem... less than fantastic in general, considering we had to do a few extra things like stripping the wires down to where there was actually enough to connect.

RamJammer

Hey All,

I just recently built the line follower and had no luck until I put the stupid map under a fluorescent light where it worked perfectly.  Apparently they tuned light sensors to only operate in Office and Schools where they only have fluorescent light!  I think it would probably work outside as well, but I haven't tried it yet. 

I tried lowering the sensors a bit using the "B-4" instead of "A-6" standoffs, but it pretty much reacted the same.  These sensors just don't seem to like incandescent too much.

I have to wonder about a few design moves with this kit, like, why 12 volts?  Isn't the Arduino based on a 5 - 6v supply?  I tried running the robot using the two 6v AA Packs in parallel to give the motors more "oomph"  but it just stuttered and did nothing, so I re-wired them in series, and it's all good again.

Yes, I did have to strip the battery back leads a bit to get them to bite and the optical sensors should have been the standard 3-wire sensor arrangement so common with Arduino, i.e. with a common negative and two positive leads.  Instead they use 2 sets of 2-lead black and red wires with 2-pin female headers on them.  These are far too easy to hook up backwards, which is what I suspect you did on your unit. 

The black and red might be correct, but the LED and phototransistor might be on the reverse headers, which would cause the problem you described.

Bottom line is, I got mine for about $ 53. at a  Radio Shack "Clearance" store, and I picked up the Expander 1 and 2 kits at the same time.  Total investment of about $ 88.  Then when I went to a regular store to get the extra motors and remote control with a $ 10.00 off coupon, I saw a whole new "make-Blocks system replacing it.  At a full blown  $300. + price tag.  Whoa.

So I have this abandoned Make:It system, but I think provides a pretty solid platform and an assortment of motors, sensors, and driver for a (now) good price.  We just have to provide our own support.

Now let's see where our imagination takes us...

aylatrigger

#4
Feb 01, 2015, 05:51 pm Last Edit: Feb 01, 2015, 07:51 pm by aylatrigger
I also got this kit from a Radio Shack closing sale. It's a good deal for what it is!

I built the walking robot first as well, and am having the same problem with one side moving. I swapped the motor leads to see if it was anything with the physical parts, but the other side went fine as well. I'm fairly confident I have the sensors hooked up right. It seems like a lot of people are having this issue. My biggest problem is that I'm having issues troubleshooting since the shield uses the serial port to communicate with the Arduino, so I haven't been able to get Serial Monitor to work. My current plan is to throw some LEDs on top to see when that sensor gets flagged. Sifting through the code now to see how it actually works. We'll see!

Edit: Ha. I figured out my problem, but I don't suspect it will help you. I had my sensors on the wrong set of header pins.  :-[

Cactusface

Hi,
    Why do you think they were selling them off, cheap. Not very good kits if you want to learn anything. Get a cheap chassis kit from China via eBay, get a driver shield (one that does NOT use the L293/298) and proto-shield, and you still have plenty to play with. Like U/S distance sensor, IR for line following, IR for remote using the TV remote, etc.

See some of my bots here:www.melsaunders.co.uk under Electronics..

Hope it helps, regards.

Mel.
Open your mind! But not too far, your brains might fall out.
Also like Photography, model building and my 300+ Cacti and Succs.

weatherjack

Same problem here with my RadioShack Make:it robotics starter kit walking robot! Has any one had luck on figuring this out? When I disconnect the sensors (on both sides) it still does the continuous one side rotation! Might be a sketch issue?

kstults

I had the same problem -- only one leg would move.

After many hours of checking all my connections over and over again, I decided to try running in an almost-DARK room.  It worked.

In my experience I have come to discover that the optical sensors are VERY sensitive to light.  As in "if there is any light" they may not work properly.

Yes, it is quite disappointing that it can only operate in this type of condition (no light), but I suppose the optical sensors are just cheap/low quality.

That's my experience -- hope it helps!

weatherjack

Radio Shack Walking robot. I have re upped the code on Arduino. Switched all sensor headers (methodically). I still cannot get the robot to alternate legs and walk. Only one leg runs in continuous rotation. If I unplug both sensors, I still have only one leg moving in continuous rotation. Can anyone confirm a working robot. I have looked for videos as well and have found no proof of a working robot!

sugartips

GUYS I HAVE FOUND THE SOLUTION ITS THE SHIELD. the places where you connect your motor wires well only n2 works (the second half). plugg both white wires into slot 3 and both black wires into slot 4. if you don't understand message me and i will give you a picture

sugartips

GUYS I HAVE FOUND THE SOLUTION ITS THE SHIELD. the places where you connect your motor wires well only n2 works (the second half). plugg both white wires into slot 3 and both black wires into slot 4. if you don't understand message me and i will give you a picture

hello23dev

Hi, I also habe the same problem. One leg walks but the other one doesn't! I only could figure out that the terminal for the motor 1 does not work.
Did anyone figured the problem out?

RoGrammer

Hello, seeing this same problem in a kit I just purchased about 1 week ago (as of 7/11/2015) from RadioShack.  I got the walking robot all put together, uploaded the Walk.ino C++ file from RadioShack (dated 2/28/2014), and am seeing only one side move. It moves continuously and exclusively.

I have tried switching the motor power wires to the opposite side--demonstrating that the other side is not 'seized up' physically--and saw now the other side moved.  I tried stuffing both power leads into the same side, but that is not a solution, as it takes away the independence of movement, and the robot still does not show any break in motion on either side.  However, this, too, shows the problem is nothing physical with regards to the drivetrain.

I also notice, that if I turn off the power switch(es), and plugin the USB cable, the robot is drawing power to move the legs, which I find rather unexpected.  Is that what others are seeing?

Please let me know of any other developments, here.

Thanks in advance.

RoGrammer

#13
Jul 12, 2015, 10:19 pm Last Edit: Jul 12, 2015, 10:24 pm by RoGrammer
Well, I want to add one more thing.  I have made a minor code change to the walk.ino file.  Although I did not read the code in great length, being somewhat a novice to the robotics domain, I did see some constants and noticed a few minor changes that looked fairly obvious.

I have not been able to verify that the DEFAULT_SPEED change did anything.  But switching the 0-speed initial setting between left and right, caused the robot to walk continuously on both sides rather than just the one.  It is for some reason never stopping.  However, at least both sides are moving.

This is, I caution, still not correct.  My understanding, is that the robot is meant to halt some amount of time between.

Like other commenters, here, I think the problem must be the sensors.  But, none of the suggested actions is working for me (fluorescent lights, darkened room).  Make this change if you wish.  I am not claiming this is the solution.

Again, if anyone finds the solution, please do post!

Here is the difference between the my modified (left), and the original (right), walk.ino file.


26c26
< #define DEFAULT_SPEED 50  //150
---
> #define DEFAULT_SPEED 150
42c42
< #define right_stop_position   10
---
> #define right_stop_position   10
76,77c76,77
<   //left_speed=150;  // default left leg on
<   Walkingrobot.walking_robot_left_leg_forward(0);
---
>   left_speed=150;  // default left leg on
>   Walkingrobot.walking_robot_left_leg_forward(left_speed);
81,82c81,82
<   //right_speed=150;  // default right leg off
<   Walkingrobot.walking_robot_right_leg_forward(right_speed);
---
>   right_speed=150;  // default right leg off
>   Walkingrobot.walking_robot_right_leg_forward(0);

RoGrammer

D'oh!  I found that the instructions had simply confused me.  There are two very similar header-pin layouts.  Both have eight pins (the right number for all the sensors), and both have similar patterns of other pins (three on one end) next to them.  I needed to wire up to the ones that sat parallel to the power input connectors, rather than the ones in an uncluttered area along one side of the white board.

Once I got that right, the sensors did get read up properly by the robot.

I am feeling much better about this purchase, now.

Go Up