Go Down

Topic: I bought a UNO R3 ATmega328P CH340G USB Driver Development Board (Read 57107 times) previous topic - next topic

TheCaretaker

I bought a  UNO R3 ATmega328P CH340G USB Driver Development Board from here:

http://www.ebay.com/itm/381042306619

When connecting it only comes up as a usb 2.0 serial port, I am unable to connect. when I try to install a driver it can't find one. I wondering if a bought the right board?

JimboZA

An Arduino factory Uno SMD is 30 USD from Sparkfun; I'd be suspicious of a 5 USD board.

But then I don't actually know what "USB Driver Development Board" means. Is it meant to be a Uno compatible device?- it certainly looks like one.

Johannesburg hams call me: ZS6JMB on Highveld rep 145.7875 (-600 & 88.5 tone)
Dr Perry Cox: "Help me to help you, help me to help you...."
Your answer may already be here: https://forum.arduino.cc/index.php?topic=384198.0

evildave_666

You need the CH340 serial driver from here. (This is the CH340 manufacturer's chinese site, I can't find the download on the english site)

ChilliTronix

The best place to get the drivers from is the Chinese site, it will be the most up to date.
Do not send technical questions as PM's they will be ignored.

TheCaretaker

Thanks

i was able to download a driver and now have the board working

scirr26

Thanks for helpful topic!
I thought the board was broken... better to buy original?

Bye

ChilliTronix

Thanks for helpful topic!
I thought the board was broken... better to buy original?

Bye
Depends on how much you want to spend. When we sell boards like this we put a link to the drivers in the listings and most people get one with them fine.
Do not send technical questions as PM's they will be ignored.

ajavgeek

If anyone is looking for help with this board...

http://kiguino.moos.io/2014/12/31/how-to-use-arduino-nano-mini-pro-with-CH340G-on-mac-osx-yosemite.html

It worked perfectly for me... The USB to Serial comm is little slower than Regular 328 based UNO but works. If your app uses lot of USB2Ser comm, then this is not for you.

Hope this helps!

brandondrury

I cussed my pair of Chinese clones of the Arduino Micro with a CH340G for about 5 hours.  It turned out a 2 minute trip to my garage to find a different USB cable solved the problem. Go figure!

Brandon

bigearsbilly

I bought a similar one, it works fine using Linux (Mint)

gg23

#10
Apr 07, 2015, 08:35 am Last Edit: Apr 07, 2015, 08:57 am by gg23 Reason: extra information

os x 10.9.3
latest arduino 1.6.3

installed as per instructions

serial port not showing in /dev directory and all arduino is giving me is as per attached image


also at the bottom of the arduino window it says:

arduino uno connected on /dev/tty.usbserial-A700eeQZ which is NOT in the list of available ports?

any help greatly appreciated

gg23

hi all,
problem solved. Found a more up to date driver through this forum and instructions here:

http://kiguino.moos.io/2014/12/31/how-to-use-arduino-nano-mini-pro-with-CH340G-on-mac-osx-yosemite.html

Now appears to be working.

Greg :)

Prakash W Dandekar

Hello All,


I am a regular buyer/user in India, of Arduino boards of all varieties, since 2011. This is first time I bought a low cost, about $7 Arduino Uno clone from eBay.in. It had a few nice things besides low price -  additional holes to mount male pins, on all connectors, adjacent to female header, so that we can use female-to-female connectors to link up other Indian accessories having male header pins. There were extra holes next to ICSP connector for Tx, Rx, +5V, 3.3V and SCL, SDA.

I had an issue with USB device driver. I quickly zeroed in on this topic and downloaded driver file from link given for Chinese manufacturer. After installing the driver, I had to disconnect and reconnect the board and then everything was fine.

I mostly use the board for training my students so it is a great buy at this low price.

BTW, I purchased two Unos in Micro Center shop in Houston, USA, two months back for $6 each. They were selling Arduino Mega for $10 and Raspberry Pi for $20. So I believe nobody should now need to pay $30 for an Arduino.

Best wishes.

-P W Dandekar
Prakash W Dandekar
Evangelist Motivator, Trainer and Speaker, Visiting Faculty in Engg colleges; Former Visiting Prof. IIT Gandhinagar & Indore, India

volthauslab

Here's another driver acquisition choice. I used the WIN7 version and it seems to work well. They also offer a Linux driver.
http://www.5v.ru/ch340g.htm

Biff

Hi,

I got my Arduino UNO clone working ok thanks to the CH340 USB drivers.
Does anyone have any info on getting the circuit schematic?

Thanks.

Go Up