Go Down

Topic: Problens uploading to Arduino Uno on Yosemite OS X 10.10 (Read 13269 times) previous topic - next topic

pjbacelar

I installed the drivers and after some headaches i made the usb port recognize the Arduino board, but when i try to upload the scripts, i get this error message:


Arduino: 1.5.8 (Mac OS X), Arduino Uno
avrdude: ser_open(): can't open device "/dev/cu.wch": No such file or directory
ioctl("TIOCMGET"): Inappropriate ioctl for device

My computer is a Macbook Pro 13' (2012) and my Arduino is a Uno R3. Can anyone give me some help?

earthbound8

I am having the same problem, has anyone helped you figure it out? i just got recieved my first arduino in the mail and i can't even upload "blink" sketch. I have spent many hours researching if anyone had the same problem but have yet to come up with a solution. I do however have an "arduino compatable" DCcEle DCcduino UNO with the ch340g chip, and i downloaded the appropriate driver from http://www.wch.cn/downloads.php?name=pro&proid=178 and even followed the directions from this website: http://kiguino.moos.io/2014/12/31/how-to-use-arduino-nano-mini-pro-with-CH340G-on-mac-osx-yosemite.html which included going into Terminal and typing in a "sudo" command. afterwards i can see the arduino in available ports but still have the error message. my mac is running Yosemite 10.10. I have ordered a legit arduino leonardo to see if it works with that one but i wont have it for a few weeks. Any ideas?

Exact same error message:
avrdude: ser_open(): can't open device "/dev/cu.wch": No such file or directory
ioctl("TIOCMGET"): Inappropriate ioctl for device
Problem uploading to board.

brezorojo

I am having a similar problem, but the difference is that I used to be able to load and now suddenly I can't.

What options do you get if you look at Tools - Port?  I used to have a usb option in there and now I only have 2 bluetooth options which are apparently not valid. 

I'm also using a Macbook Pro, but I might fire up my old Windows laptop tomorrow to see whether I can get round it that way.  My USB sockets work fine with everything else, just not with the Arduino.

earthbound8

Under "tools/port" when i have my arduino connected it shows up as:
Code: [Select]
/dev/cu.wch ch341 USB=>RS232fd120 I am still having problems and i can't find anyone else who has come into this problem before and come up with a solution. I am eager to learn and start experimenting but cannot even get past step one!

dass83

Hi guys!

Considering you have correctly installed the CH340G driver, the problem is in the spaces of the device name.
To fix that you have to manually edit two (2) txt files of the arduino installation.

Go where you have installed it. In my case the path is:

/Users/MY_USERNAME/Downloads/Arduino.app/Contents/Java/hardware/arduino/avr

Inside this directory you can see files platform.txt & programmers.txt.

Inside these files replace -P{serial.port} with "-P{serial.port}".
So you simply have to add the quotes.

One occurrence is in the first file & two in the second.

Restart your IDE and it will work! Enjoy!

deschnell

Thank you, thank you, thank you!!! Exactly what I needed to solve my problem with the same board!!

dlack

I just got the Leonardo and was prompted to uninstall the previous Arduino data(that i had for the Uno) and did. I did the thing where the drivers are installed and so forth, I set the "board" status to Leonardo. But when to upload to get a response from the board nothing happens. The green On indicated is lit along with the blinking L. Any suggestions?

Markusimus

Hi dass83, thanks you for that it works for me as well :)

twilson

I'm in the same boat that it seem like a lot of people are in: Mac OS, seeing "USB2.0-Serial" in System Information that appears/disappears based on whether I have my daughter's Arduino plugged in, but in the IDE: Serial is grayed out and the only two options are Bluetooth ones.

I've tried multiple cables and multiple Macs to no avail. This is for a "Duinokit Jr.", which appears to be an Arduino Uno, and their site linked to this specific thread.

I've installed (and reinstalled) the CH341G driver for Mac.

The instruction to try editing the platform.txt and programmers.txt files seems like something else I should try... but I can't find them. I can't actually find the "arduino.app" folder. I've got the IDE running, and I'd moved it into the Applications folder after I downloaded it. I've unhidden all folders/files, but I can't find the files that are supposed to be edited. I've searched the entire Mac for both the individual files and the folders to no avail. That has me wondering if I don't have something installed correctly.

I apologize if this is a "learn how to use a Mac, dummy" question rather than a true "get the Arduino port issue addressed." I'm stuck.

twilson

Go figure. After multi-hour runs at this on two separate occasions...as soon as I posted here I seem to have found something that did the trick.

The comment from dmatyukhin in this post: https://forum.arduino.cc/index.php?topic=261375.0

Check out that post for the full details, but it did boil down to (I think) both having the CH340G/CH341 driver installed, running a command in Terminal (sudo nvram boot-args="kext-dev-mode=1"), and then restarting.

Excalibur83

#10
Jan 24, 2016, 10:45 am Last Edit: Jan 25, 2016, 09:20 am by Excalibur83
Hi guys!

(...)
Go where you have installed it. In my case the path is:

/Users/MY_USERNAME/Downloads/Arduino.app/Contents/Java/hardware/arduino/avr

Inside this directory you can see files platform.txt & programmers.txt.

Inside these files replace -P{serial.port} with "-P{serial.port}".
So you simply have to add the quotes.

One occurrence is in the first file & two in the second.

Restart your IDE and it will work! Enjoy!
Note that there are 4(four) -P{serial.port} in second files (programmers.txt) . You can find it easily using menu Edit/Search>and Replace (truly in french menu Edition/Rechercher>Rechercher et Remplacer).
However, you should edit only the first and second. I didn't try modified all of them and it WORKS !
EDIT :
At least it works with OS 10.9.5. However, I've failed with Capitan.
Edit ended.

Also, note that probably depending on your OS, you have to modifie using Terminal :

sudo ln -s /dev/cu.wch\ ch341\ USB\=\>RS232\ 1420 /dev/cu.wch upto Mac OS 10.9.5
or
sudo ln -s /dev/tty.wch\ ch341\ USB\=\>RS232\ 1420 /dev/tty.wch for Yosemite or Capitan.

These command line are for Arduino Nano, it could change depending on board and/or config.

Watch on error message in your IDE to know exactly what it expects for.

EDIT (25 jan):
I forgot that Capitan 10.11.2 introduced a new USB serial driver. Probably the reason modifications doesn't work.

Go Up