Go Down

Topic: Materia Servo and temperature Issue. (Read 2135 times) previous topic - next topic

w9jds

Hello! I need some help. I assembled the Materia and right away everything worked but the x servo, the extruder servo, and the ambient temperature sensor.

Whenever I try to move the x axis or the extruder stepper the device throws a:
Error:0
: Extruder switched off. MINTEMP triggered !
Error:Printer stopped due to errors. Fix the error and use M999 to restart. (Temperature is reset. Set it after restarting)
The device always says extruder temp/0 degrees.

I went through all the potentiometers and they are all at the values specified. I also went ahead and swapped out the x for the y stepper and extruder for the y stepper. when I move the y both servos worked just fine. So it isn't the cable or the stepper either. I'm truly at a loss on what I should do. Since I just got it.

w9jds

#1
Feb 02, 2015, 10:12 pm Last Edit: Feb 02, 2015, 10:49 pm by w9jds
I found out what is wrong with the servos. Looks like the two drivers where bad. I pulled out the two and put the extra extruder one in the extruder spot and that server started working again. Still no idea on the temperature though.

kengdahl

Hello!

I am sorry I missed you post here. We also have a support email that goes strait to my inbox.

If you want new stepper drivers I'll send you a few.

w9jds

So I tested it out and did a ton of troubleshooting and found it wasn't the motors it was actually the servo drivers on the shield. I didn't hear anything so I ordered a couple from online and got them yesterday. I popped them in and my temperature issue went away and all my servos work now. The only thing now is that those O clamps for those rails, I was short four. Other than that the printer is working perfectly now.

kengdahl

We would love to send you a few extra as a compensation for your troubles.

w9jds

That would be cool. Thanks! Otherwise I love the product. Took a ton of calibration but totally worth it  :D

kengdahl

Please email me you information and the email you used to order the materia101 at materia101@arduino.cc

Go Up