Go Down

Topic: Ma led sur le Digital output ne brille pas aussi fort qu'avec une pile 4.5 V (Read 959 times) previous topic - next topic

alex16p

Bonsoir,

Je suis débutant et épargnez-moi si cette question vous paraîtra sotte:

J'ai branché une led sur ma arduino uno alimenté par un cordon usb depuis mon ordinateur. En utilisant les sorties digitales, j'ai mis mon pin digital "13" au niveau "high". La led s'allume, il n'y a pas de soucis, cependant l'intensité lumineuse n'est pas aussi élevée qu'en branchant ma led sur une pile de 4.5 V.

J'ai cru comprendre que les sorties digitales délivraient une tension de 5V.

Alors pourquoi la led sur l'arduino brille moins ?

Cheers

68tjs

La question n'est pas sotte elle soulève un problème important.
Je vais encore une fois rigoler sur les 40 mA par sortie indiqués par arduino et revenir sur un sujet maintes fois abordé.

Les gens de chez arduino annoncent fièrement qu'on peut faire débiter 40 mA à une sortie.
D'abord c'est faux, c'est juste toléré pendant de courts instants (Absolute Maximum Rating), le courant max en service permanent annoncé par Atmel n'est que de 20 mA. Comme c'est Atmel qui a conçu le micro on peut croire qu'ils savent ce qu'ils ont fait.

Ensuite les sorties supportent 20 mA, oui, mais ce n'est pas sans conséquences.
Les transistors de sortie du micro sont de tout petits transistors prévus pour piloter des circuits logiques.
Comme ils sont tout petit ils ont une résistance résiduelle (Rdson) de plusieurs dizaines d'ohms.
Ce qui fait qu'une sortie délivre 5 Volts A VIDE mais à 20 mA elle ne délivre plus que 4,48 V à 20°C PUCE et non pas température ambiante. A 20°C de température ambiante il faut compter entre 20 et 70°C de plus pour la puce selon ce qu'on lui fait débiter.

C'est donc normal d'autant qu'une pile de 4,5V neuve fait souvent plus de 4,5 Volts.


Go Up