Go Down

Topic: When using the Arduino IDE for the first time, I receive an error message: (Read 5771 times) previous topic - next topic

The-Nerd-

"You forgot you sketchbook - Arduino cannot run because it could not create a folder to store your sketchbook".
I'm using a Vista (bleurgh, I know) PC and an UNO R3 board. I downloaded the IDE from the proper page, following instruction from my starter kit. I tried running the IDE from the desktop icon, and - yay, an error!
I know it's probably something I need to change in the preferences .txt file, but I'm not sure what!

Thanks in advance for any replies,
-The-Nerd-

CrossRoads

I used a Vista laptop and many variations of the IDE for 4 year when I started, I had no problems with it. Way better than 8.1.

Under File:Preferences, enter path where your sketches and user libraries will be stored, such
as
C:/Windows/Users/YourName/Documents/ArduinoStuff
Make sure the folder exists and that you have rights/authority/privilege/properties/whatever setup to access it freely.

I use Win7Pro on my new Lenovo W530 Laptop.  Mrs Crossroads has Win8.1 on her W530, she can't stand the features that just make it toy-like for the masses vs an engineering tool.

Designing & building electrical circuits for over 25 years.  Screw Shield for Mega/Due/Uno,  Bobuino with ATMega1284P, & other '328P & '1284P creations & offerings at  my website.

The-Nerd-

Hello again!
Thanks CrossRoads!
I have one question however:
When you say File:Preferences, do you mean the file preferences.txt? (If so, what do I add to the file?)
If not, do you mean the File menu within the IDE itself? That'd be a problem, as the problem I am having is that the IDE itself is refusing to open

Thanks!
-The-Nerd-

CrossRoads

I meant from within the IDE.

You can try this area within preferences.txt, I've not tried changing this directly:
Code: [Select]

# DEFAULT PATHS FOR SKETCHBOOK AND SETTINGS

# relative paths will be relative to processing.exe or procesing.app.
# absolute paths may also be used.

# note that this path should use forward slashes (like unix)
# instead of \ on windows or : on macos or whatever else

# If you don't want users to have their sketchbook default to
# "My Documents/Processing" on Windows and "Documents/Processing" on OS X,
# set this to another path that will be used by default.
# Note that this path must exist already otherwise it won't see
# the sketchbook folder, and will instead assume the sketchbook
# has gone missing, and that it should instead use the default.
#sketchbook.path=

# if you don't want settings to go into "application data" on windows
# and "library" on macosx, set this to the alternate location.
#settings.path=data

# temporary build path, normally this goes into the default
# "temp" folder for that platform (as defined by java)
# but this can be used to set a specific file in case of problems
#build.path=build

# By default, no sketches currently open
last.sketch.count=0
Designing & building electrical circuits for over 25 years.  Screw Shield for Mega/Due/Uno,  Bobuino with ATMega1284P, & other '328P & '1284P creations & offerings at  my website.

The-Nerd-

That fixed it! I made a new folder on my desktop called Arduino Sketches, and in preferences.txt I added the line sketchbook.path="C://Users/"MyName"/Desktop/Arduino Sketches
Thanks for your help, CrossRoads, and may this, admittedly small, thread be a help to any other people with the same issue!

-The-Nerd- :D  :D


garthandercraft

Hi The-Nerd

I am experiencing the same issue.

Where was your preferences.txt file located that you added the line to?

I can only find  one, **/Arduino/lib/preferences.txt, which doesn't allow me to save changes :-(

Any assistance welcome

Thanks
Garth

RedQuark

I think a much better solution to this problem, rather than editing the preferences.txt file, is to run arduino.exe as an Administrator (right-click and select "Run as administrator"). It worked for me.

Go Up