Go Down

Topic: Arduino Mega2560 -Burned regulator and USB controller (Read 630 times) previous topic - next topic

kubus66

Hello. I'm at the stage of building a 3D printer (actually almost finished). Unfortunately i managed to burn Arduino MEGA (I manually moved stepper motor and it has acted as a generator). However, despite burned voltage regulator (AMS1117) and the USB controller (CH340G) printer still worked properly controlled by the LCD screen with a potentiometer and gcode from the SD card. But the computer does not detect the arduino and I needed to upload the updated soft to operate the printer. I have arduino UNO and want to use it to program MEGA.
So I hooked up the pins:
UNO>>> MEGA
10 >>> RESET
11 >>> 51
12 >>> 50
13 >>> 52 
5V>>> 5V
GND>>> GND
Also tried to hook the ICSP connector on MEGA.
UNO>>> MEGA ICSP
10 >>> 5
11 >>> 4
12 >>> 1
13 >>> 3
5V >>> 2
GND>>>6
I also tried to repeat these operations with ~ 10uF capacitor between GND and RESET at UNO (supposedly required to turn off the auto-reset). But somehow it does not work. Of course i upload ArduinoISP on UNO, and then in the IDE I used "Upload using programmer" with set MEGA as a target board.
When I use the command "Burn Bootloader" gets the message after all:
avrdude: verification error, first mismatch at byte 0x1e000
0xff! = 0x0d
avrdude: verification error; content mismatch
And the LED L MEGA blinks ~ 2 times per second. On the internet I found that this message does not necessarily mean bad loaded bootloader, but when I upload any program (even Blink) Mega does not respond (although IDE returns to the upload completed successfully) and the LED L is lit constantly. What am I doing wrong, or should be doing differently?
I tried the method described here: http://www.gammon.com.au/bootloader and the program says that the bootloader is uploaded correctly (L LED is blinking), and even later check will also gave me a message about the correct bootloader(see below). But still I am not able to properly upload even simplest sketch on MEGA.

When i use Atmega_board_detector i get:
Atmega chip detector.
Written by Nick Gammon.
Version 1.12
Compiled on Feb 16 2015 at 17:08:31
Attempting to enter programming mode ...
Entered programming mode OK.
Signature = 1E 98 01
Processor = ATmega2560
Flash memory size = 262144 bytes.
LFuse = FF
HFuse = D8
EFuse = FD
Lock byte = EF
Clock calibration = 89
Bootloader in use: Yes
EEPROM preserved through erase: No
Watchdog timer always on: No
Bootloader is 8192 bytes starting at 3E000
...
MD5 sum of bootloader = 12 AA 80 07 4D 74 E3 DA BF 2D 25 84 6D 99 F7 20
Bootloader name: atmega2560_bootloader_watchdog_bug_fixed
So bootloader looks fine, i'm confused.

Go Up