Go Down

Topic: Enviar SMS Sim900 Quadband (Read 5520 times) previous topic - next topic

Ruben_LP

Hola a todos.

Estoy tratando de enviar SMS desde mi shield GSM Quadband sim900 conectada a Arduino Uno sin gran éxito de momento. Lo cierto es que logro enviarlos con conexión usb desde el monoitor serial utilizando el código "SendSMS" facilitado en ejemplos. Sin embargo, al intentar enviarlo sin conexión USB y conectando la placa Arduino Uno a una fuente de 12V 2A, los SMS no se envían. A continuación les dejo el código que utilizo y en enlace de la web de donde lo he sacado.

Muchas gracias por su atención les agradecería mucho vuestra ayuda. ;)



http://tronixstuff.com/2014/01/08/tutorial-arduino-and-sim900-gsm-modules/




#include <SoftwareSerial.h>
SoftwareSerial SIM900(7, 8);
 
void setup()
{
  SIM900.begin(19200);
  SIM900power(); 
  delay(20000);  // give time to log on to network.
}
 
void SIM900power()
// software equivalent of pressing the GSM shield "power" button
{
  digitalWrite(9, HIGH);
  delay(1000);
  digitalWrite(9, LOW);
  delay(5000);
}
 
void sendSMS()
{
  SIM900.print("AT+CMGF=1\r");                                                        // AT command to send SMS message
  delay(100);
  SIM900.println("AT + CMGS = \"+654321000\"");                                     // recipient's mobile number, in international format
  delay(100);
  SIM900.println("Hello, world. This is a text message from an Arduino Uno.");        // message to send
  delay(100);
  SIM900.println((char)26);                       // End AT command with a ^Z, ASCII code 26
  delay(100);
  SIM900.println();
  delay(5000);                                     // give module time to send SMS
  SIM900power();                                   // turn off module
}
 
void loop()
{
  sendSMS();
  do {} while (1);
}

Ruben_LP

Hola de nuevo.

Por si puede ser de ayuda,  les dejo el enlace de una web donde se puede ver las características del Shield GSM que precisamente tengo.
Gracias.

Ruben_LP

http://hetpro-store.com/TUTORIALES/modulo-de-comunicacion-inalambrica-gsm-shield/

Ruben_LP

Hola a todos.

Estoy tratando de enviar SMS desde mi shield GSM Quadband sim900 conectada a Arduino Uno, sin gran éxito de momento. Lo cierto es que logro enviarlos con conexión usb desde el monoitor serial utilizando el código "SendSMS" facilitado en ejemplos. Sin embargo, al intentar enviarlo sin conexión USB y conectando la placa Arduino Uno a una fuente de 12V 2A, los SMS no se envían. A continuación les dejo el código que utilizo y en enlace de la web de donde lo he sacado.

Muchas gracias por su atención, les agradecería mucho vuestra ayuda. ;)



http://tronixstuff.com/2014/01/08/tutorial-arduino-and-sim900-gsm-modules/




#include <SoftwareSerial.h>
SoftwareSerial SIM900(7, 8);
 
void setup()
{
  SIM900.begin(19200);
  SIM900power(); 
  delay(20000);  // give time to log on to network.
}
 
void SIM900power()
// software equivalent of pressing the GSM shield "power" button
{
  digitalWrite(9, HIGH);
  delay(1000);
  digitalWrite(9, LOW);
  delay(5000);
}
 
void sendSMS()
{
  SIM900.print("AT+CMGF=1\r");                                                        // AT command to send SMS message
  delay(100);
  SIM900.println("AT + CMGS = \"+654321000\"");                                     // recipient's mobile number, in international format
  delay(100);
  SIM900.println("Hello, world. This is a text message from an Arduino Uno.");        // message to send
  delay(100);
  SIM900.println((char)26);                       // End AT command with a ^Z, ASCII code 26
  delay(100);
  SIM900.println();
  delay(5000);                                     // give module time to send SMS
  SIM900power();                                   // turn off module
}
 
void loop()
{
  sendSMS();
  do {} while (1);
}

harold92

Sino me equivoco no has cambiado la posición de los jumpers para alimentarlo externamente.


ASTROCAR

#5
May 01, 2016, 11:08 am Last Edit: May 01, 2016, 11:16 am by ASTROCAR
hola buen dia disculpa lo tarde pero segun las caracteristicas de tu shield tienes que tener cuidado con esto:
SoftwareSerial SIM900(2, 3); // Configura el puerto serial para el SIM900
 
y viendo el codigo que estas trabajando usas:
SoftwareSerial SIM900(7, 8)
que es para otro modelo de shield y no el que estas usando.

otra diferencia tambien que vi es que el modo de encendido por software en tu shield es el pin 8 mientras que en el codigo esta en el pin9.


saludos y espero mi comentario sean de tu ayuda hermano.

surbyte

A todos los involucrados, usen tags para insertar códigos.
estas cosas son inaceptables SoftwareSerial SIM900(7, 8)

se usa esto </>

Code: [Select]
SoftwareSerial SIM900(7, 8)

Tanto no cuesta no?

Go Up