Go Down

Topic: avrdude: ser_open(): can't open device "\\.\com3": (Read 92334 times) previous topic - next topic

FredKD

Had similar problem yesterday with my UNO R3. See my reply comment (#3 - FredKD) on "port selection in tools is grayed out". Once I refreshed my "ports" driver on my PC everything began running ok. I ran across a comment somewhere that said that, sometimes, communications with the Serial Monitor gets corrupted and may cause this "port" issue.

pgscherer

Guys, sorry to insist on the same issue, but I've tried pretty much everything in every forum or tutorial and no success.
I borrowed my brother's Arduino, actually Makerduino Uno V3, from Makerstudio. Their site says it uses FT232 instead of ATMega 16u2.
When I first plugged the board to my laptop, Windows 8.1 64 bits, it automatically completed the instalation and I was able to upload Blink. After disconnecting the board and reconnecting, it no longer worked. When I connect it, device manager shows 'FT232R UART' as an unknown device. If I install Arduino Uno R3 driver, or any other Arduino driver, it will give me an error message, device manager will show the yellow exclamation mark (as in attached pic1.jpg), and Arduino IDE Ports menu will appear grayed out (pic2.jpg). If I change the driver to FTDI, it won't show the error message or the yellow mark. Device manager will show USB Serial Port (pic3.jpg) and the port number will appear normally on Arduino IDE Ports menu (pic4.jpg). But it won't upload anything to the board! Now the error messages appear on the IDE, and are different when I try to upload a sketch (pic5.jpg) or the bootloader (pic6.jpg).

Could  you, please, help?

Thanks!

paralaile

Hello,
have you selected in Tools the type of the board?
(sorry for my English)

csmiley

I am having the same problem with my Arduino UNO...it was working fine the first day I installed it, but then the next day my PORT was grayed out and when I tried to upload the sketch, the same error message appeared. 
I think the problem lies with Windows 8.  I found a u-tube video through another post that seems to temporarily work: https://www.youtube.com/watch?v=CdE72XUYC7k
Basically you are tricking the computer to think your arduino is a modem...I have no idea how they figured that all out.
The problem is, I have to repeat this whole procedure every time I restart my computer.  I switch to another COM # every time.  I'm really hoping Windows 10 doesn't have this issue.   

pdd33734

  I purchased a "Genuine" Arduino Uno and played around with it, and did not have communication problems with it. I put it into a project while I purchased a replacement for it so that I could get it back, and, continue to experiment with it.
  I bought the "replacement" Arduino from the same location that I bought my parts for the project. The replacement(s), an aftermarket Nano and ATMega2560 are both giving me "avrdude: ser_open(): can't open device "\\.\COM3": The system cannot find the file specified."
  Soooo, my questions are: (1) What file is it looking for?, and (2) Why does this problem still exist (since 2009)? Clearly I am not the first person to encounter this problem, but, I sit here researching this problem on the web, and in this forum for a solution, none of which seem to apply to my situation.
  I am using a Dell laptop w/ Windows 7, Arduino IDE 1.6.5, and a Nano ATMega328 v3 compatible. I was simply trying to verify operational state before I substitute this device in place of my Uno. This device has never been tampered with by me. I just opened the ESD bag, plugged it into the computer/IDE and tried to load "Blink". I did identify the "board" and "processor" for the IDE, but, COM was (and still is) grayed out. It identified the connection as a "USB2.0-Serial" device on COM 3. No existing COM conflicts appear to exist. It does say the driver is not installed! Soooo, where is the driver?
  I have tried every feasible driver search and install, to no avail. What do I do next?

Bella1

Hi!

I have a pretty similar problem. Arduino MEGA 2560 R3 and RAMPS 1.4 board came to me with "Prusa i2 3D printer DIY set" to plug in like on this schematics: http://3dprinter.my/abante/resources/image/18/a2/9.png. Working on Win7 (64bit) MSI laptop, I downloaded newest stable Marlin package, putted it into Arduino IDE, picked right board and processor type, and finally tried to upload, but 'Tools/Ports' was greyed out from very beginning, so it turned back with an error:
Code: [Select]


avrdude: ser_open(): can't open device "\\.\COM1": can't open device.

(and in effect:)

avrdude: ser_drain(): read error: invalid path.

When plugging printer to laptop, it's identified as "USB2.0-Serial", localised in Port_#0002.Hub_#0001 and cant's find drivers (code 28). You can switch it's ID in properties to Arduino Mega 2560 and update drivers, but then it can't start (code 10).

I tried updating drivers in Device Manager, disabling WiFi and Bluetooth, hiting Restart button on MEGA, restarting IDE, printer and laptop (it's Windows after all) and nothing changed. I'm out of ideas. Please help!

Revoir

I had this same problem but I went into device manager unistalled the drivers for the "faulty" board and it automatically switched from com8 to com3 and it seemed to be working fine.

stevo4705

i actually had the same problem that all of you have, and my fix was as simple as uploading the sketch with out anything connected to the arduino except the USB cable.

vbbartlett

I also have the same problem.  My board was working fine and then in the device manager I disabled it.  That is when everything became problematic.  Im on windows 10 and the device manager acts differently than previous version.  I constantly get "Unknown USB Device( Device Description Request Failed)"  To get it to show I had to hold the reset down while plugging in and then release it (Timing is everything...).  Once I was able to get it connected, I had to enable it again.
But I now have to use the same reset technique to connect. This allows the Arduino Uno to be somehow get a Device Description and it is registered to Com3. 

But this still doesn't fix the can't set com-state msg, which is what I get when attempt to upload an empty program.

Any one have similar problems?



SivaN

could not get my USB 3 to work. switched to USB 2 and......works

ljfaraci

had the same problem with com1: in Windows 10


avrdude: ser_open(): can't open device "\\.\COM1": The system cannot find the file specified.


updated all my drivers - still an issue.

Looked at the device manager (devmgmt.msc) for "ports (COM & LPT)" and found Arduino was on COM3.

Had to modify the preferences.txt file to fix the problem

preferences.txt file path found in file>preferences menu when Arduino is running.

To modify the text file, shut down Arduino and modify the file in notepad.

Line to modify is "serial.port=COM1"  changed to "serial.port=COM3" and saved file

Fixed.



padmanabhank

Hi,

here is my situation - I got my first Arduino(Uno) last week. I successfully uploaded and ran quite a few programs on it. Only today when I connected it to my computer, I got this error-avrdude: ser_open(): can't open device "\\.\com3": the system cannot find the file specified....

 The "port" under tools menu is grayed out, even with the board connected. It used list COM3, if I had the board connected before. Now I can't find the Arduino in the device manager either!

I was working on an obstacle avoiding bot, and I uploaded a code for it last night. When I connect the Arduino to my computer, the power LED glows and that code runs. I wanted to change the code a bit tonight, but couldn't because of this problem.

I am running 64 bit Windows 8.1. My brother has the same OS. After some frustration with this, I connected the Arduino to his laptop for the first time only to get more frustrated - its the same problem there. No drivers start getting installed, the device manager doesn't show any new devices. It's as if the computers don't know if anything got connected to them!

I hope I could make my problem clear. Any help would be greatly appreciated. As I already said, this is my first Arduino, so you can assume I have virtually no experience with micro-controllers before.
********PROBLEM SOLVED (For me atleast)********
1. Reconnect the board to another USB port.
2. Look at the bottom left corner of the screen once the board is connected. It should display a message on the lines of - "Installed Drivers Successfully for Arduino COM(*number*)
3. Note down the number attached to COM. In my case it was 7.
4. Open the file "preferences.txt" from the preferences menu in the arduino console, and then close the console.
5. Scroll down to - serial.port = COM1. Change the '1' to the number that you noted down earlier.
6. Reopen Arduino and it should work. Voila.
Hope this helps :-)

hassen_tayech

 i did solve the problem guys,

go to control panel in windows, and uninstall the com driver that arduino is using

unplug the arduino and plug it again and it will install the com driver automatically

go in arduino software to TOOLS then PORT and check the new com that says where the arduino board is connected

and done :)

xrabidkatzx

THANKS SO MUCH Peki SERIOUSLY I WAS ABOUT TO BUY A NEW ATMEGA

LanGenz

I have a simple solution that worked for me ... I changed my USB cable and it worked again

Go Up