Go Down

Topic: Problema con el modulo HC-05 bluetooth (Read 46318 times) previous topic - next topic

fcasanova


joqquezada

Aureliano24. Estoy con el mismo problema que te sucesio a vos. me pasa exactamente lo mismo, con el celu se conecta pero la aplicacion hecha por mi tira error de conexion. me podrias dar una mano por fa? muchas gracias

joqquezada

Aureliano24. Estoy con el mismo problema que te sucesio a vos. me pasa exactamente lo mismo, con el celu se conecta pero la aplicacion hecha por mi tira error de conexion. me podrias dar una mano por fa? muchas gracias

julioego

Tambien tengo el mismo problema  parece que no recibe ninguna señal de mi app y no logro entrar al modo AT por ningun tutorial

tengo el hc-05 con el botonsito
y arduino mega alguien ya lo solucionó?

julioego

Tambien tengo el mismo problema  parece que no recibe ninguna señal de mi app y no logro entrar al modo AT por ningun tutorial

tengo el hc-05 con el botonsito
y arduino mega alguien ya lo solucionó?

kamiluo

Buenas,

A mi me pasó lo mismo, lo que tienen que hacer es verificar cual tipo de Modulo Bluetooth tienen en mi caso es el ZS-040 HC-05.

La conexión está en el adjunto con nombre DiagramaConexion.jpg, la particularidad de este modulo es que no necesita conectarse la PIN 34. Los pasos de configuración se explican en el siguiente Link. De todas formas ese tutorial te muestra la manera de usar el PIN 34 para otros tipos de Modulos BT.

Espero les sirva...

jcarbajalm

Hola , hice un proyecto con el H05 y Leonardo, pero no puedo conectar mi celular con el Bluetooth, lo sincronizo, ero nunca se establece la conexión, la configuración que uso es la misma que muestras, pero sin éxito. como puedo saber que esta fallando

CrisLovan6

#22
Aug 24, 2015, 03:52 am Last Edit: Aug 24, 2015, 03:52 am by CrisLovan6
Logré hacer que mis aplicaciones de android funcionen . Lo que no logro todavía es entrar en el modo AT.
hola, yo tambien tengo el mismo problema, estoy haciendo las app en app inventor pero no funciona, como hiciste para que te funcionara?

Gracias

CrisLovan6

Buenas,

A mi me pasó lo mismo, lo que tienen que hacer es verificar cual tipo de Modulo Bluetooth tienen en mi caso es el ZS-040 HC-05.

La conexión está en el adjunto con nombre DiagramaConexion.jpg, la particularidad de este modulo es que no necesita conectarse la PIN 34. Los pasos de configuración se explican en el siguiente Link. De todas formas ese tutorial te muestra la manera de usar el PIN 34 para otros tipos de Modulos BT.

Espero les sirva...
hola. el link solo es para los comandos AT?

BOWTeam6

Olvide mencionar que en tu caso que tienes el HC05 con un boton, debes mantenerlo pulsado y seguidamente conectarlo a los 3.3v de Arduino, cuando veas que el led rojo parpadee lentamente es que esta en modo AT.

JOSE_249

Hola, no se si solucionaste tu problema.  El módulo que viene con el botoncito es para ponerlo en modo AT

Para ello debes
1- Desconectar la alimentación (VCC o GND)
2- Presionar el botón y mantener presionando
3- Conectar la alimentación sin dejar de presionar el botón
4- Cuando el led comience a parpadear lento entonces puedes soltar el botón y mandar los comandos AT

Espero te sea útil

inori28

Bueno el mismo problema me ocurre a mi eh leido varios foros y aun no encuentro la solucion a este problema, ya hice eso de conectar y esperar a que parpade cada 3 segundos apretando el boton antes de conectar el vcc, pero cuando voy al monitor serial y escribo el "AT" sin las comillas, no me sale nada ya revise el baulio 9600 todas las configuraciones y aun no logro entrar al at del BT. mas bien lir por ahi que lograron conectarlo a sus aplicaciones de android, me gustaria siquiera el dato para tambien interntarlo mientras se busca una solucion para poder configurar el BT.

Adrian_E

en este link encontre todo lo que necesitaba, tengo un hc-05 gw-040 https://translate.google.com.ar/translate?hl=es-419&sl=en&u=http://www.martyncurrey.com/arduino-with-hc-05-bluetooth-module-at-mode/&prev=search

rafaellopez

Logré hacer que mis aplicaciones de android funcionen . Lo que no logro todavía es entrar en el modo AT.
Buen dia aureliano hay un canal de youtube que se llama editronix alli en su capitulo 11 hablan de como poner a funcionar los hc-05 solo que el de el no tiene el boton como el tuyo o el mio y le solda un puente, que hice yo segui el tuto al pie de la letra con el boton presionado y pude configurar el hc-05, bien en mi tlf se empereja pero no puedo conectarlo a mis apk android ¿como pudiste hacerlo tu?

madepablo

#29
Jan 04, 2016, 11:12 am Last Edit: Jan 04, 2016, 12:26 pm by madepablo
Saludos,

Pues ayer por la tarde me llego mi HC-05 (uno de esos con botoncito, y de código GW-040), y estaba como vosotros con que no podía acceder al modo AT. Pero tras explorar por internet y hacer muchas pruebas, al final lo conseguí de forma muy rápida. Por si les ayuda, les dejo mis pasos con un Arduino Nano.

1) Conexiones:

HC-05       Arduino
STATE               (sin conectar)
RX            10
TX            11
GND          GND
VCC          5V
KEY           3V3 (No se si hace falta, pero yo lo puse)

2) Sketch
Usé el modo 3) de esta página:http://www.martyncurrey.com/arduino-with-hc-05-bluetooth-module-at-mode/
con una modificación de los pines software serial. El código me quedó así:

Code: [Select]
#include <SoftwareSerial.h>
SoftwareSerial BTserial(10,11); // RX | TX

char c = ' ';
 
void setup() {
    Serial.begin(9600);
    Serial.println("Arduino is ready");
    BTserial.begin(9600); 
    Serial.println("BTserial started at 9600");
}
 
void loop(){
    if (BTserial.available()){ 
        c = BTserial.read();
        Serial.write(c);
    }
    if (Serial.available()){
        c =  Serial.read();
        Serial.write(c);
        BTserial.write(c); 
    }
}


3) Ejecución
Subid el código y abrid el puerto serie con el Arduino IDE usando el puerto COM correspondiente a vuestra placa. Yo le puse en el modo "Ambos NL&CR" y 9600 Baudios.
El módulo HC-05 se enciende y parpadea rápidamente. Ahora dadle al botoncito (seguirá parpadeando igual, pero habrá entrado en modo comandos AT).
Escribid AT y dadle al intro... debería devolveros un OK.

Y ya está!, ya podeis aplicar cualquier cambio que queráis con comandos AT, por ejemplo, como los que proponen aquí: Ver paso 4. Podéis ponerlo en maestro/esclavo, cambiarle el nombre, etc, etc. Bueno, ya sabéis. Lo que yo hice fue asegurarme de que ahora en adelante el módulo si o si tiene velocidad 9600 baudios. Para eso usé el comando AT+UART=9600,1,0  Con eso ya no tengo problemas de si se comunica a 38400 baudios.

Una vez acabado de hacer cambios en el módulo, lo desconectáis y listo para trabajar!
Espero que os sirva. A mi me resolvió la vida (con el HC-05, quiero decir).

4) Extras
Y ya de paso, si queréis que se conecte automáticamente a otro dispositivo H-06 escalvo o un HC-05 en modo esclavo, no tenéis más que seguir estos pasos: Conexión de 2 dispositivos automáticamente

Espero que os haya sido de utilidad.
un saludo,

Go Up