Go Down

Topic: Expanding arduino yun storage (Read 13509 times) previous topic - next topic



I've tried to expand my Arduino Yun's storage with the YunDiskSpaceExpander script, and I got this error:
Code: [Select]
You don't have enough disk space to install the utility software. You need to free at least 1MB of Flash memory.

How can I free memory on my Arduino?



What size SD did you purchase to put in the Yun? Is it brand new? Or is it used?
Did you have an Internet connection?

Have you used the YunSerialTerminal yet?



I had the same issue, and i was not sure what i can safely uninstall using opkg.. so:

- I did the new YunSysupgrade install (if you have already done it before - you can just reset your YUN by holding down the Arduino's WiFi reset button for more than 30 seconds ) and THEN run the new version of the YunDiskSpaceExpander script.

That worked for me.


How can I free memory on my Arduino?
It's the space that's on the internal flash file system that is the issue. You Linux system volume is (almost) full and there isn't room to install the utilities necessary to format and setup the SD card. It's probably not too surprising to hear that your system volume is full, since you're trying to make room there, you've probably noticed you're running out of room.

If you created any large data files or log files on the Linux side (on the internal file system, not saved to an SD card) then try deleting some of them. Or if you installed some large software packages (probably using opkg) remove some.

Run the "df -h" command on the Linux side, and make sure you have at least 1 MB of free memory on the root ("/") volume before trying the expander sketch again.

Or, you can do as miticv suggests, which will delete everything and return back to the factory default state, at which point you will have lots of free space.


Good afternoon everyone,

I tried to perform the SDcard expansion but I'm encountering an error:
You don't have enough disk space to install the utility software. You need to free at least 1MB of Flash memory.

1) I removed installed packages using opkg remove package
2) performed the "./reset-to-factory-anyway procedure", and
3) rebooted my Yun Rev2

and the message of "You don't have enough disk space to install..." continues.

What else I can do for overcoming this issue?

Also when I perform the "./reset-to-factory-anyway" procedure this prompt appears:
  " message /dev/mtdblock5 is mounted as /overlay, only erasing files"

How I can correct it?

root@Arduino:~# df -h
Filesystem                Size      Used Available Use% Mounted on
/dev/root                 8.8M      8.8M         0 100% /rom
tmpfs                    29.3M     88.0K     29.2M   0% /tmp
/dev/mtdblock5            5.6M    316.0K      5.3M   6% /overlay
overlayfs:/overlay        5.6M    316.0K      5.3M   6% /
tmpfs                   512.0K         0    512.0K   0% /dev

Víctor Rainier Cruz Pérez.

Go Up