Go Down

Topic: Sublime Text 3 problemas y soluciones (Read 38035 times) previous topic - next topic

surbyte

Continúo informando. Pasé de la alegría al fracaso.
Desinstalo todo, y no sirve. Borro en C:\archivos de programa\Sublime Text (tengo versión 64bits)
y borro en

C:\Usuarios\MiUsuario\AppData\Roaming\Sublime Text // Carpeta completa

Instalo. Y sale sin funcionar y con menúes en gris. No hay manera de reestablecerlo.

noter

Pues te cuento mi experiencia.
Sublime Text 3083 + arduino 1.6.3 aparentemente funcionando. Hasta hoy me daba siempre error de compilación, pero he hecho lo de borrar la carpeta de appdata y ya parece que compila.
Eso sí, quitando el package manager. Simplemente copiando en la carpeta sublime/data/packages la carpeta stino. Previamente borré todo lo que había en data/packages/user.

surbyte

pues he hecho como 3 veces eso Serafín y sigo con todo en gris.
Ahora voy a mi casa y voy a poner el ST2. Ya me aburrí.
No puedo usar mas el IDE porque lo siento Tosco. Y ya me acostumbre al ST que no puedo usar tampoco el Atmel Studio que tarda tanto en cargar.

gepd

surbyte, ¿puedes subir una captura de los menús en gris que te aparecen?
Deviot el plugin IoT para Sublime Text. Si quieres probarlo y ayudarme con tu feedback, visita: https://github.com/gepd/Deviot

surbyte

Parece que ahora se ha despertado bien, y solo requería de un reinicio general, de hecho han pasado dias desde que no lo uso en esta máquina.
Seguiré atengo y les comento.
Ahora los menúes grises no aparecen.
Lo malo es que no se que hice que resolvió el problema porque he hecho tantos cambios que no se si podría ayudar a alguien con los pasos realizados.
Básicamente borré la instalación
en c:\archivos de programa\Sublime Text
y en C:\USUARIO\AppData\Roaming\Sublime Text

surbyte

Bien, me quedó una máquina mal, y aca pongo una imagen de como luce



Puedo sumar información de como estan los directorios si sirve para analizar la situación.

gepd

#51
Jun 07, 2015, 10:37 pm Last Edit: Jun 08, 2015, 04:30 am by gepd
Luego de mucho buscar y buscar, he encontrado la solución a algunos problemas, el primero, que Sublime Text no eliminase la carpeta new-stino del directorio de packages y el segundo un error que decía

Quote
"avr-g++' is not recognized as an internal or external command, operable program or batch file.
Usando el IDE 1.6.4


Lo primero, es que gracias a un usuario del repositorio de stino, recomendó una nueva forma para instalar el plugin, los pasos son:


  • Eliminar cualquier versión previa del plugin, estable o beta (incluyendo Arduino like-ide).
  • Abrir la paleta de comando (Tools->Command Palette) y elegir 'Package Control: Add Repository'.
  • Copiar el link edl siguiente repositorio https://github.com/Robot-Will/Stino/tree/new-stino y pegarlo en la ventana.
  • Abrir nuevamente la paleta de comando (Tools->Command Palette) y selecionar 'Package Control: Install Package' búsca el paquete llamado 'Stino'. Asegúrate de no seleccionar el paquete llamado 'Arduino-Like IDE.'(versión antigua)


Esos serían los pasos para instalarlo, una vez eligen la carpeta del IDE 1.6.4 e intentan compilar algún script, les parecerá el error que escribí más arriba, para solucionarlo abren el directorio con los plugins instalados "Preferences->Browse Packages..." y en la carpeta Stino/preset del plugin. reemplazan el archivo que dejé adjunto en este post, reinician Sublime Text y les debería funcionar


EDIT: He comprado que aún existe un problema al intentar subir el script al la placa, estoy investigando que puede ser, por ahora debería funcionar sin problemas conversiones anteriores a la 1.6.2. Apenas tenga una novedad les escribo aquí mismo
Deviot el plugin IoT para Sublime Text. Si quieres probarlo y ayudarme con tu feedback, visita: https://github.com/gepd/Deviot

_jose_

Es normal que las salidas por el serial monitor acaben con un cuadrado al final de la linea?

surbyte

El serial monitor del ST para mi es regular tirando a malo.
Se me ha colgado un par de veces, no se a Uds. Cuando hago lo mismo con el IDE, no pasa nada.

Si aparece un cuadrado es un byte no codificable en ASCII. Podría indicar CR o LF. 0x10 o 0x13 si mal recuerdo.

gepd

Como dice surbyte, ese es un byte no codificable en ASCII o texto según lo tengas configurado, si vas a Arduino-> Serial Monitor -> Line Ending, puedes seleccionar el caracter con el que quieres que termine, si no me equivoco, al seleccionar none, ya no aparece nada.

Por cierto yo no tengo muchos problemas con el monitor, aunque se me ha quedado colgado, no ha sido en tantas ocasiones.
Deviot el plugin IoT para Sublime Text. Si quieres probarlo y ayudarme con tu feedback, visita: https://github.com/gepd/Deviot

gepd

Bueno he solucionado los problemas del plugin con la versión del IDE 1.6.4, he creado un nuevo fork con estas mejoras, pueden descargarlo desde: https://github.com/gepd/Stino

Las instrucciones de instalación están en el mismo repositorio o en: http://forum.arduino.cc/index.php?topic=305229.msg2266651#msg2266651
Deviot el plugin IoT para Sublime Text. Si quieres probarlo y ayudarme con tu feedback, visita: https://github.com/gepd/Deviot

surbyte

Que nivel gepd.. funciona para atrás? Debe hacerlo no?

gepd

Por el momento no, en las últimas versiones han modificado dos veces un archivo y debo agregar algunas variables para cambiar esos archivos según la versión, pero estoy en ello. Y ya te digo que en la 1.6.5 se viene otro cambio, pero lo mas importante es que ya sé cual es el problema. 

Seguiré informando en este post.
Deviot el plugin IoT para Sublime Text. Si quieres probarlo y ayudarme con tu feedback, visita: https://github.com/gepd/Deviot

gepd

Corrijo, según las pruebas que estuve haciendo, no debería haber problemas con otras versiones, pero de todas maneras quién se encuentre con uno me lo hace saber para poder ayudar
Deviot el plugin IoT para Sublime Text. Si quieres probarlo y ayudarme con tu feedback, visita: https://github.com/gepd/Deviot

max_saeta

#59
Jun 15, 2015, 05:01 pm Last Edit: Jun 15, 2015, 05:18 pm by max_saeta
Saludos
sigo con el problema de
Quote
"avr-g++' is not recognized as an internal or external command, operable program or batch file.
para versiones superiores a 1.6.0.

Lo he probado en SB2 y SB3 ninguna mejora he seguido los pasos de gepd.

He decidido usar SB2 porque SB3 aun contiene muchos bugs, incluyendo errores al compilar los sketch que usan SPI, como el de webserver.

Go Up