Go Down

Topic: Sublime Text 3 problemas y soluciones (Read 37225 times) previous topic - next topic

gepd

Max no he podido reproducir tu error, pero por mientras, puedes solucionarlo ejecutando el siguiente comando (en la consola de comando):

Code: [Select]
setx path "%path%;C:\arduino-1.6.4"

Sólo debes cambiar la ruta correspondiente a donde tienes instalado tu IDE
Deviot el plugin IoT para Sublime Text. Si quieres probarlo y ayudarme con tu feedback, visita: https://github.com/gepd/Deviot

max_saeta

Max no he podido reproducir tu error, pero por mientras, puedes solucionarlo ejecutando el siguiente comando (en la consola de comando):

Code: [Select]
setx path "%path%;C:\arduino-1.6.4"

Sólo debes cambiar la ruta correspondiente a donde tienes instalado tu IDE
Ya instale la versión 1.6.0 y por los momentos me quedo con ese. Solo si necesito soporte para otra placa lo cambiare.

surbyte

Tambien yo estoy con 1.6.0 y de momentos funciona bien. En una PC logre que funcione en otra no.
No se que hice porque probé tantas cosas y de golpe funcionó.

gepd

Hoy actualicé el repo de stino, ahora es posible trabajar con las últimas versiones del IDE sin necesidad de hacer ninguna otra modificación. Agradeceré a quien pueda probarlo y comentar sobre la solución. Yo estoy trabajando con Windows 8.1 y funciona perfectamente.
Deviot el plugin IoT para Sublime Text. Si quieres probarlo y ayudarme con tu feedback, visita: https://github.com/gepd/Deviot

scraw

No sé si este hilo es sólo para ST3 o para ambos, en cualquier caso me va perfectamente y a la primera la versión de gepd en OSX 10.10.5, ST 2.0.2 y Arduino IDE 1.6.5 - R5. Probado con placas UNO R3 y Leonardo.

Buen trabajo gepd, estaba hasta las pelotas de editar en ST y tener que pegar código al IDE para subirlo.

surbyte

Tengo problemas con ST3 de nuevo y no puedo hacer que funcione. Arroja este error y parece ser que no va bien con IDE 1.6.0 que es el que tengo y debo tener 1.6.5 que no instalaré.

El error es al intenatar compilar

Code: [Select]
[Stino - Start building "Prueba"...]
[  3%] Creating C:\Users\Ricardo\AppData\Local\Temp\Stino_build\Prueba\Prueba.ino.cpp.o...
El nombre de archivo, el nombre de directorio o la sintaxis de la etiqueta del volumen no son correctos.
[Stino - Exit with error code 1.]

surbyte

Bueno ya lo resolvió gepd con quien estoy en contacto. Pronto publicará la solución en el sitio Stino de Github.
Gracias gepd!!

gepd

Como ya comentó surbyte, he corregido el problema que generaba un error con distintas versiones del IDE, después de los cambios que hice pude compilar con el IDE 1.6.0 - 1.6.5 - 1.6.7

Si tienen algún problema pueden escribir aquí e intentaré solucionar

he subido los cambios a esta rama: https://github.com/Robot-Will/Stino/tree/new-stino
Deviot el plugin IoT para Sublime Text. Si quieres probarlo y ayudarme con tu feedback, visita: https://github.com/gepd/Deviot

surbyte

Acabo de reinstalar ST3 desde 0 y funcionó perfecto en Win 7 64 bits y en Win 10

noter

Hola, gepd.

¿Podrías poner un post-resumen con la información actualizada? A saber:

- Link de repositorio Stino (haces referencia en el hilo a dos url distintas)
- Versiones de Arduino/sublime soportadas.
- Si se ha de instalar de forma manual o mediante package control.

He instalado Arduino 1.6.4, sublime 3103, y he añadido stino mediante package control, y no hay manera  >:( . Anteriormente, con la 1.6.0 pude solucionarlo instalando manualmente y modificando algunos archivos, pero no me gustaría tener que pasar otra vez por aquel suplicio  ::).

Muchas gracias ;).

gepd

#70
Feb 26, 2016, 02:49 am Last Edit: Feb 26, 2016, 03:12 am by gepd
Hola noter, disculpa por no haber respondido antes pero anduve sumergido totalmente en otro asunto y estuve desaparecido del foro.

El repositorio de stino que "funciona" es: https://github.com/Robot-Will/Stino/tree/new-stino la instalación debe hacerse manualmente y según mis pruebas, funciona con el IDE 1.6.0 - 1.6.5 - 1.6.7.

Como es un código que se convirtió muy problemático y el desarrollador original anunció que trabajaría en una nueva versión (sin fecha de nada) yo desistí de hacer cualquier cambio en stino.

Pero he estado trabajando en Deviot, una opción que en la ultima versión (1.1.0) requiere de sólo dos cosas, Python 2 y el plugin. Luego de instalar python en tu computadora, descargas el plugin desde el package control y todo lo necesario para funcionar se descarga automáticamente, no requiere del IDE de Arduino, y estoy constantemente trabajando en el para mejorarlo y agregar nuevas funciones.

PD: en este momento package control aún apunta a la versión 1.0.0, no sé cuanto demora en actualizarse, por si lo instalas y te encuentras que la auto-instalación no funciona.
Deviot el plugin IoT para Sublime Text. Si quieres probarlo y ayudarme con tu feedback, visita: https://github.com/gepd/Deviot

surbyte

Bueno he estado usando Deviot y tengo algunas sugerencias menores. 
Lo importante es que trabaja bien.
No he podido descargar librerias cuando Deviot me dice que esa librería no forma parte de su soporte.
Mi solución siempre ha sido agregarla a la carpeta de librerías personales.
El hecho es que llevo 4 y cada compilación esta tardando mas y mas tiempo y cuando veo los temporales, estos incluyen todas las librerías.
Una cuestión que me gustaba de Stino es que podia crear un nuevo sketch pero Deviot no tiene esa simple opción.
Por el momento el resto me gusta y de hecho lo estoy usando como compilador primario.

gepd

Gracias surbyte, en esta nueva versión he corregido el problema que no reconocía las librerías, tomo nota para agregar la opción de crear un nuevo sketch desde el menu y revisaré el tema de como se compila el firmware con varias librerías, tengo varias mejoras de rendimiento pendientes, pero llegarán luego.

Gracias por los comentarios y sugerencias!
Deviot el plugin IoT para Sublime Text. Si quieres probarlo y ayudarme con tu feedback, visita: https://github.com/gepd/Deviot

surbyte

Como dije, son cosas para igualar en operatividad a Stino que para mi es cómodo.
Yo mantengo el IDE y para mi también sería grato que DEVIOT si ve que el IDE esta presente al menos tome las librerías presentes en el IDE para su uso. 
Tal vez no sea la idea base de DEVIOT que vi que pusiste mucho énfasis en que se descarguen del sitio web correspondiente. Pero por ahora yo y creo que muchos lo iríamos haciendo conforme DEVIOT nos vaya devolviendo esa confianza. Que la tiene pero quienes venimos de un ambiente como IDE/STinto, estamos siempre en transición.

surbyte

#74
May 25, 2016, 08:46 pm Last Edit: May 25, 2016, 08:48 pm by surbyte
Otra vez con problemas. ST 3 build 3134 corriendo bien perooooo siempre hay un pero.
Estoy con IDE 1.6.5 que correctamente hace su trabajo. Incluso con DUE.
ST usando STINO no ve el DUE y no he encontrado solución alguna en la web que lo resuelva.
Podría postear los dos o tres intentos pero ya digo, no funcionan o no resuelven el problema.

Go Up