Go Down

Topic: Hex Upload? (Read 4992 times) previous topic - next topic

freakyuser

Hallo zusammen,

mit der Arduino IDE bekomme ich ein Programm auf meinen Uno,
wenn ich aber AVRdude mit folgenden Parametern benutze bekomme ich nur ne Fehlermeldung. (not in sync)
Ne Idee worans liegt?

Code: [Select]
-F -v -pm358p -cstk500v1 -P\\.\COM3 -b19200 -D -Uflash:w:"C:\Users\Spielrechner\Documents\test.hex":i

Grüße


lord-maricek

Als ich noch Ubuntu drauf hatte, musste ich immer "arduino" als Programmer eingeben.

MfG
Philipp

freakyuser

Und unter Windows (vista 64Bit)?

saw0

#3
Jan 10, 2011, 05:05 pm Last Edit: Jan 10, 2011, 05:06 pm by saw0 Reason: 1
-F -v -pm358p -c stk500v1

das leerzeichen bei cstk fällt auf.

Benutz doch mal die avrdude gui, und kuck obs damit läuft?

http://sourceforge.net/projects/avrdude-gui/


freakyuser

Hilft au net, un die GUI hängt sich nur auf

saw0

#5
Jan 10, 2011, 06:30 pm Last Edit: Jan 10, 2011, 06:31 pm by saw0 Reason: 1
Quote

Windows (vista 64Bit)


::)

Was hängt sich da auf, was geht nicht?

"Geht au net" bringt hier keinen weiter.

lord-maricek

Haste die GUI bzw. avrdude auch als Admin ausgeführt?
Es gibt da immer so ein paar Spezialisten, die das nicht machen.

MfG

freakyuser

#7
Jan 11, 2011, 04:06 pm Last Edit: Jan 11, 2011, 04:15 pm by freakyuser Reason: 1
türlich hab ichs au als admin probiert, bei der IDE brauch ich des übrigends net.

Hier nochma die genaue Ausgabe

Code: [Select]
C:\Users\Spielrechner\Desktop\ArduinoUploader>avrdude -F -v -pm328p -cstk500v1 -
P\\.\COM3 -b19200 -D -Uflash:w:"C:\Users\Spielrechner\Documents\test.hex":i

avrdude: Version 5.10, compiled on Jan 19 2010 at 15:10:54
        Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
        Copyright (c) 2007-2009 Joerg Wunsch

        System wide configuration file is "C:\Users\Spielrechner\Desktop\Arduin
oUploader\avrdude.conf"

        Using Port                    : \\.\COM3
        Using Programmer              : stk500v1
        Overriding Baud Rate          : 19200
avrdude: stk500_getsync(): not in sync: resp=0x00

avrdude done.  Thank you.


Ich meine damit das sich die GUI aufhängt, reagiert halt nicht mehr.
Und das Leerzeichen bringt auch nichts.

Könnte jemand vielleicht die Parameter mal bei sich ausprobieren, bzw. mir ma ne andere hex für den uno schicken?

Grüße freakyuser


saw0

Bist du sicher, dass es COM3 ist?

Der 328er braucht 57600 baud, warum overridest du mit 19200 baud?

freakyuser

#9
Jan 11, 2011, 04:56 pm Last Edit: Jan 11, 2011, 05:10 pm by freakyuser Reason: 1
Weis nich mehr wo ich die her hab.

Code: [Select]
-F -v -p m328p -c stk500v1 -P\\.\COM3 -b 57600 -D -Uflash:w:"C:\Users\Spielrechner\Documents\test.hex":i

funktioniert aber au net.
COM 3 müsste stimme, die Rx LED leuchtet immer ganz kurz.

Die IDE nutzt doch auch avrdude, kann man irgendwie herausbekomme mit welchen parametern?

auf meinem XP Notebook geht übrigends au net.

saw0

Achso du benutzt irgendwelche Parameter von denen du gar nicht weisst was sie bedeuten?

Was sollen denn die Backslashes  bei
Quote
-P\\.\COM3
?

Welcher Port ist denn in der IDE eingestellt, der müsste ja dann passen?




freakyuser


saw0

#12
Jan 11, 2011, 05:54 pm Last Edit: Jan 11, 2011, 06:01 pm by saw0 Reason: 1
Ohne Backslashes auch keine Besserung?

Quote
Using Port : \\.\COM3


Das kann nicht gehen, den Port gibts nicht.

freakyuser

ne hilft au net, könntest du bei dir vielleicht mal ausprobieren welchen code ich benutzen muss?

saw0

Da ich keine offiziellen Arduinos benutze, sondern nur seeeduinos und iteaduinos ist das glaub ich nicht nützlich :)

Go Up