Go Down

Topic: Can not upload to Arduino MEGA 2560 (Read 4623 times) previous topic - next topic

oskarslanina

Arduino: 1.6.0 (Mac OS X), Board: "Arduino Mega or Mega 2560, ATmega2560 (Mega 2560)"

In file included from Marlin.h:23:0,
                 from BlinkM.cpp:5:
pins.h:2078:2: error: #error Oops! Make sure you have 'Brainwave 2' selected from the 'Tools -> Boards' menu.
 #error Oops!  Make sure you have 'Brainwave 2' selected from the 'Tools -> Boards' menu.
  ^
Error compiling.




This is what it says when I try to upload Marlin firmware to my Arduino MEGA 2560 board. What should I do? (this is the first time i am dong something like this). Thanks for support

cmiyc

Capacitor Expert By Day, Enginerd by night.  ||  Personal Blog: www.baldengineer.com  || Electronics Tutorials for Beginners:  www.addohms.com

AJITnayak

Send your complete code with associated library so we can check what mistake you have done. As james said ; i think you created own library which not included in program properly
AMPS

oskarslanina

Marlin is actually a 3D printing firmware downloaded from github. https://github.com/jcrocholl/Marlin
I opened it in Arduino IDE, changed some dimensions and tried to upload it but then the error message that I showed you started to show up. I tried to redownload it several times but nothing worked. Even basic sketches like BLINK do not want to upload. But the board seems to be OK physicaly:
-when I put a LED in the GND and 5V port it lights up.
-when I try to reset it it does what it has to-stops blinking for a second or two and then starts to blink again

I tried even changing my USB cable and nothing worked. Do you thing the problem should be in the computer? Thanks for all your support and help. I appreciate every help.

PS: Do you really want me to write the code here? It has got c/a 400 lines.

cmiyc

Even basic sketches like BLINK do not want to upload. But the board seems to be OK physicaly:
Do you get the same error message?

In Arduino IDE's Preferences, turn on Verbose Output for Compliation and Upload, then paste the results here between code tags.
Capacitor Expert By Day, Enginerd by night.  ||  Personal Blog: www.baldengineer.com  || Electronics Tutorials for Beginners:  www.addohms.com

oskarslanina

Thanks for your answer. Now I do not have acces to a computer but I will try to do what you said ASAP. Thanks a lot again.

oskarslanina

Hi.
I tried doing what you told me but i am still getting the the same error message:


Code: [Select]
In file included from C:\Users\Lenovo\AppData\Local\Temp\build2078353183707947364.tmp\Marlin.h:23:0,
                 from C:\Users\Lenovo\AppData\Local\Temp\build2078353183707947364.tmp\BlinkM.cpp:5:
C:\Users\Lenovo\AppData\Local\Temp\build2078353183707947364.tmp\pins.h:2078:2: error: #error Oops! Make sure you have 'Brainwave 2' selected from the 'Tools -> Boards' menu.
 #error Oops!  Make sure you have 'Brainwave 2' selected from the 'Tools -> Boards' menu.
  ^
Error compiling.


What should I do now? I am absolutely desparate.
 Thanks for all your support and help again.


cmiyc

Where did you download the IDE from?
Capacitor Expert By Day, Enginerd by night.  ||  Personal Blog: www.baldengineer.com  || Electronics Tutorials for Beginners:  www.addohms.com

oskarslanina

Hi,
I downloaded it from here www.arduino.cc
-the official arduino site
I downloaded the Windows installer version by the way.

cmiyc

If you downloaded the IDE from arduino.cc and you are trying to compile the basic blink sketch, and you're getting errors about "Marlin.h" and "Brainwave" (which I still have no idea what those are), then I can't help you. 

That mix doesn't make any sense.
Capacitor Expert By Day, Enginerd by night.  ||  Personal Blog: www.baldengineer.com  || Electronics Tutorials for Beginners:  www.addohms.com

oskarslanina

Do you think buying a new one would help?

cmiyc

No.  The problem is in the software.  You haven't gotten to the point of programming a board yet.

I would re-download the software, put it in a different directory, and double check that you have the correct port and board settings.
Capacitor Expert By Day, Enginerd by night.  ||  Personal Blog: www.baldengineer.com  || Electronics Tutorials for Beginners:  www.addohms.com

zoutepopcorn

Maybe try some other library's.

Or watch this https://www.youtube.com/watch?v=uQ5mU6Ye4PU, howto set your hardware. I had the same problem on my new computer. I have to find my old library, with the right configuration, then it will work...

Go Up