Go Down

Topic: [Résolu] Problème de drivers avec l'Arduino Mega 2560 avec le CH340G (Read 6695 times) previous topic - next topic

Zyaxi

Bonjour à tous,

Je me suis récemment procuré un Arduino Mega 2560 (ce n'est pas la version officielle). Tout content de mon nouveau jouet  :D , je me suis précipité à mon ordinateur pour le brancher et ainsi tester un programme que j'avais codé. Mais quand j'ai connecté, Windows a essayé d'installer les drivers mais n'y est pas parvenu (merci Microsoft).

J'ai donc essayé de les installer "manuellement" en allant dans le gestionnaire de périphériques/Autres périphériques/USB2.0-Serial (c'est le nom que prend mon Arduino pour l'instant)/[clic droit/mettre à jour le pilote]/rechercher un pilote sur mon ordinateur/rechercher parmi une liste de pilotes de périphériques sur mon ordinateur/Ports (COM et PLT) et j'ai sélectionné en fabriquant Arduino LLC et en modèle Arduino Mega 2560, et quand je clique sur "suivant", j'ai un message comme quoi Windows ne recommande pas l'installation, je poursuis quand même l'installation du pilote, Windows me dit qu'il a bien trouvé le driver mais qu'il n'a pas réussi à l'installer et il me donne un code d'erreur (code 10).

Pourriez-vous m'aider à trouver une solution?
Merci d'avance.

PS:
-je suis sur W7
-je sais que la question a déjà été posée, mais je n'ai pas encore trouvé des personnes dans mon cas.

dfgh

hello
de memoire, lorsque l'on installe IDE ARDUINO, il faut donner le chemin C:\program(x86)\arduino\drivers\FTDI USB Drivers.
je suppose que pour une installation manuelle c'est la meme chose. ( je suis sous W8.1 et en UNO)
si cela peut t'aider...

Zyaxi

Merci, mais j'ai un message de Windows comme quoi il n'a pas trouvé de drivers pour le périphérique.

dfgh

oui, mais lors de la manip tu n'as pas le choix entre laisser Windows chercher sur l'ordinateur et donner toi meme le chemin ( parcourir)

Zyaxi

Oui, c'est ce que j'ai fait, j'ai mis cette adresse  C:\Program Files (x86)\Arduino\drivers\FTDI USB Drivers et après j'ai le message comme quoi Windows n'a pas trouvé de drivers.
Et je ne peut pas sélectionner de fichiers, je suis obligé de sélectionner un dossier

fdufnews

Tu es certain que ta carte est équipée d'un boîtier FTDI?

Zyaxi

Je ne sais pas. Voici la photo de la carte que j'ai commandé si ça peut t'aider:   http://puu.sh/hpAIS/c9def788e2.jpg

fdufnews

C'est indiqué sur la photo. Le boîtier d'interface est un CH340G.
Quelque chose là:http://forum.arduino.cc/index.php?topic=289619.0
ou là:http://forum.arduino.cc/index.php?topic=299022.0

Zyaxi

C'est bon, mon Arduino est reconnu sans aucun problème. J'ai fait un rapide test avec "Blink" et il n'y a pas d'erreurs de compilation.

Voici le lien des drivers pour le CH340G: http://dl.krapazok.com/driver-ch340g.zip

Et encore merci à tous pour votre aide

Go Up