Go Down

Topic: IDE 1.6.4 is now available for download (Read 29391 times) previous topic - next topic

billfilson

I purchased the SainSmart UNO R3+2-Channel 5V Relay Starter Kit and it arrived this week ok.

The processor on the board is the ATMEL MEGA328P. I downloaded this IDE Vers 1.6.4. (Windows 7)

I have been trying, without success, to get it to download the "blink" program.
After Verifying the code I then attempted to upload the program and got the following error:

"avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_getsync(): timeout communicating with programmer"

I consulted the troubleshooting guide section "Why I can't upload my programs to the Arduino board?" and tried to follow the instructions.

Since there was no direct reference to this processor in the IDE menu "tool=>board" drop-down menu I set it to "Arduino Mega or Mega2560"
I installed the USB (COM10) driver as "Arduino UNO" (I also tried to re-install a number of other drivers as well without success).

I notice some of you in this forum have the ATMEGA328P processors and Windows 7. Has someone got some tips?

Isaac96

So you couldn't find the UNO on the Tools>Board menu?
Do not PM me for help. I will delete immediately.
CONNECT THE GROUNDS!

After Tuesday, even the calendar goes W T F

billfilson

Worked fine - Thanks
I was misled by the reference to "Mega2560" in the Tools=>board drop down menu. I was looking for something like "Mega328P". Silly me !!

federicofissore

polypagan try downloading it again: one month after 1.6.4 release, this is the first time I read of such a problem on linux (on windows it may be due to a crappy antivirus)

wabbitguy

While the printer output is better with the Mac 1.6.4 version, it seems to have lost the ability to do a printout of the keywords in colour like the 1.0.6 version did. Everything is black and white.

Any chance of getting colour printer output reinstated, or at least as an option?

The IDE still insists on opening the last sketches as "postage stamps" on the bottom left corner of the monitor. Aka the most glaring bug will be the one that proves to be longest to get fixed... :o

federicofissore

#110
Jun 12, 2015, 08:56 pm Last Edit: Jun 12, 2015, 08:57 pm by Federico Fissore
We are short in macosx hackers. Feel free to pick one issue and give a hand :) https://github.com/arduino/Arduino/issues?q=is%3Aopen+is%3Aissue+label%3A%22OS%3A+OSX%22

wabbitguy

I'm only a Mac software developer, thus platform specific and I don't do Java. Except in a cup from Starbucks.

Kevin Marinelli

I am having a problem printing sketches to my HP LaserJet printer. All I get are blank pages.
The same happens when I print to a PDF document.

I am running IDE 1.6.4 on a Macintosh computer running MacOS 10.10.3.



Thanks.

Kevin Marinelli

The bug is that when opening a sketch from an older version of the IDE, printing outputs blank pages.

Saving the sketch in the new IDE, and then printing then produces the correct output!

A very strange bug.

Isaac96

Do not PM me for help. I will delete immediately.
CONNECT THE GROUNDS!

After Tuesday, even the calendar goes W T F

jboyton

When I quit the 1.6.4 IDE it also closes the file that is in the foreground, forcing me to reopen it next time I invoke the IDE. So, unlike 1.0.6, when I quit 1.6.4 I always first open a dummy file so that it closes that instead of the file that I've been working with.

I don't know if this is OS X specific or if it's been mentioned here before or already fixed; or for that matter, I don't know if the Arduino IDE team considers it a bug or an intentional feature. To me it's a bug. I am only using 1.6.4 for one project, reluctantly.

polypagan

Thank you, Federico!

1.6.5 seems to cure most of my troubles (has install.sh, which was missing from 1.6.4-linux32).

Still can't get Digistump to install, but perhaps I can sort that myself.

There are 10 kinds of people in the world, those who understand binary, and those who don't.

theanh1089

So you couldn't find the UNO on the Tools>Board menu?
kệ để hàng tạp hóa, kệ siêu thị giá rẻ

qseovn

Looks like this was a permissions issue - I was able to fix it by running
in tem bảo hành, in tem vỡ, in tem,

Go Up