Go Down

Topic: IDE 1.6.4 is now available for download (Read 29333 times) previous topic - next topic

federicofissore

Uhm it may be due to some network errors. Follow these steps:

  • Open File > Preferences
  • Click on "preferences.txt" at the bottom of the window
  • Delete/Rename the "staging" folder.



This will cause the IDE to re-download all previously downloaded core files

websammy

Hi Federico,

I deleted the folder but it still fails, it downloaded a sam-1.6.4.tar.bz2 file, I tried opening it with WinZip but it is still corrupted. Any other suggestions? Can I do it manually?

Regards,
Sammy

N3kr0manc3r

Can any kind soul please shed some light on how to modify Serial buffer sizes and I2C bus speeds for the Arduino Due in the new IDE?

With the 1.5.x versions there was a sam folder under hardware/arduino. I don't see that with the new 1.6.4 version even after using board manager to install the Sam cores

pYro_65

Can any kind soul please shed some light on how to modify Serial buffer sizes and I2C bus speeds for the Arduino Due in the new IDE?

With the 1.5.x versions there was a sam folder under hardware/arduino. I don't see that with the new 1.6.4 version even after using board manager to install the Sam cores
On windows the cores and board info is located here (if your name is Chris): C:\Users\Chris\AppData\Roaming\Arduino15

On linux, I believe its kept in the home folder.
Forum Mod anyone?
https://arduino.land/Moduino/

websammy

I fixed the CRC error by going to a different network, apparently the firewall at work was blocking the connection somehow.

Seomonas


Apatura

Now I'm using IDE 1.6.4 whenever I open a sketch, ie File>Open, the sketch shown in the file picker window isn't the last one I saved, it shows the penultimate one I saved.  

Is this a known bug?

Thanks,

Paul

federicofissore

It should show the last one you opened not the last one you saved

iw2fvo

I have error messages when trying to install 1.6.4 om my PC running win 7 64 bit .
Error opening files for writing
c:\programfiles(x86)\Arduino\Java\bin\awt.dll....
Any help please ?
Thanks
Ambro

sveinutne

#24
May 19, 2015, 10:23 pm Last Edit: May 20, 2015, 12:11 pm by sveinutne
I am having a problem running the IDE on my Windows 8.1 64bit HP laptop. I installed IDE 1.6.4 and when I launch the IDE the splash screen shows up, and at the bottom the following messages are displayed in order;

Loading configurations...
Initializing packages...


Then the splash screen goes away and the IDE never comes up. There are no error messages associated with this problem and I even tried the previous version of the IDE with the same results.

sveinutne

#25
May 20, 2015, 08:17 am Last Edit: May 20, 2015, 12:13 pm by sveinutne
I must admit that my problem started before the instalation of IDE 1.6.4.
I was running IDE 1.6.2 and got a new DUE board, and tried to download software for this board. Something went wrong, and IDE 1.6.2 stoped working. Instead of fixing the problem, I uninstalled it, and looked for a new version. Then I downloaded 1.6.4 and installed it with no error wornings, but it would not start completly. It disapeared after the line Initializing packages came up. Then I uninstalled 1.6.4 and installed 1.6.3 with the same result. Then I unistaled it and retried 1.6.2 but no luck. Now I have reinstalled 1.6.4 but with the same result.
I hope someone got a suggestion, because I was going to use the Arduino for a project this week.
Is there a way I can start the IDE in debug mode to see where it goes wrong?
Regards
Svein

federicofissore

Please start the IDE using arduino_debug.exe from a command prompt. It will print an error message: please paste that error here

sveinutne

Could not past the picture in her, but I can type it:
Loading configuration. . .
Initializing packages. . .
processing.app.debug.TargetPlatformException: Fant ikke boards.txt i C:\Users\Svein\AppData\
Roaming\Arduino15\packages\arduino\hardware\sam\1.6.3 Er filen pre-1.5?
at (processing app.debug.LegacyTargetPlatform.<init>(LegacyTargetPlatform.java:67)
---
There are a lot more, and I have a print screen of it. If you have an email address, I can mail it. I could not past the picture in here.
Regards
Svein

federicofissore


Apatura

It should show the last one you opened not the last one you saved
I know! Well, it doesn't!!  It's really annoying.

Go Up