Go Down

Topic: "Not enough disk space"-Error while using diskexpander-Sketch (Read 3468 times) previous topic - next topic

Siccc

Hi all,

I want to install node.js to my Yun. I recognized that it's required to expand the Yuns memory to an additional sd card, so I want to use the sketch to do so.

Unfortunately, after fighting with the serial monitor, I got the error message that I don't have enough disk space.

I checked the sd card. It's brand new and FAT 32 formatted.

Any suggestions to solve this problem and go through with the installation?......thank you very much

Greetings
Siccc

ShapeShifter

The problem is not the SD card, but the internal flash memory. In order to expand onto the SD card, some utilities must be installed to partition the SD card and then copy the required software to the card. The installer script is complaining that there is not enough internal flash memory to install those utilities.

You need to uninstall some previously installed utilities, or remove some of the larger files that you previously created on the internal flash storage.

Siccc

Hi shapeshifter,

first oft all, thnk you very much for your post. I had no idea, that the flash memory is mentioned. How can I make some free space in there? In my opinion the only content inside is the diskexpander-sketch. Am I wrong with that?

Could you give me some suggestions how to make space?

ShapeShifter

I think you're getting the memory spaces confused.

First off, there are two processors on the Yun board:
  • ATmega32U4 - an 8 bit processor that runs the Arduino sketch and manages the shield I/O pins
  • AR3391 - a 32 bit ARM core system on a chip that runs Linux and manages the networking and SD card


The '32U4 has 32 kB of internal flash where the sketch is loaded, and 2.5 kB of internal RAM for variables.

The AR3391 has 16 MB of flash, and 64 MB of RAM. A portion of that on-board flash is set up to emulate a disk drive, and is used to boot Linux. This processor also has a socket for an optional SD card for additional storage.

The memory regions of the two processors are completely independent, and one processor's memory cannot be used in any way by the other processor.

Before running the disk expander sketch, the AR3391 boots Linux from the on-board flash memory's emulated disk drive. Any software that is installed, or data files that are created, are actually stored in the limited on-board flash memory space. If an SD card is inserted, that memory is available as an additional data storage volume.

After running the disk expander sketch, the AR3391 still starts booting Linux from the on-board flash memory's emulated disk drive, but partway through the process it maps a disk volume from the SD card as the system root volume, and continues booting from there. Once fully booted, any software that is installed, or data files that are created, are actually stored on the SD card, not in the on-board flash memory space, even if stored to the system file areas.

Now, to successfully run the disk expander sketch the sketch must be loaded into the '32U4 processor's internal flash, the AR3391 processor must be booted up from on-board flash, and that on-board flash must have enough free space to install the required card formatting and volume copying utilities.

The insufficient disk space message is referring to the emulated file system in the AR3391's on-board flash. Before you tried running the disk expander sketch, I'm guessing that you have installed some software on the Linux drive (or created some large files) and got messages about low disk space. That's probably what prompted you to run the disk expander sketch. If that's the case, you will need to uninstall some of the software packages, delete some of the large files you created, or reset the board to factory defaults (which will undo everything you've done so far.)

Once you free up some space on the on-board Linux file system (which is in on-board flash memory) you should be able to run the expander sketch.

Siccc

Wow....thanks a lot for your explicit description. You was right about my confussion.
Before I tried to run the sketch, I run opkg for an unsuccessfull Installation of node.js.
Tomorrow I will remove this files and run the sketch again.

I will post the results here...

Once again....thank you very much.

ShapeShifter

Before I tried to run the sketch, I run opkg for an unsuccessfull Installation of node.js.
Yeah, that would probably do it!

jessemonroy650

Quote from: Siccc
Quote from: Siccc on Today at 02:58 pm

    Before I tried to run the sketch, I run opkg for an unsuccessfull Installation of node.js.
Yeah, that would probably do it!
I've made that dumb mistake, and went down the same path. I took a different route out.

Jesse


Siccc

#8
Jun 02, 2015, 10:39 am Last Edit: Jun 02, 2015, 10:48 am by Siccc Reason: Problem is solved
So....first issue is solved. Now there is an error message that told me that the required software intsallation is failed, after updating the software list. I definitely have an internet connection.

When I take a look inside the code, it seems that the list update is successfull, so opkg update works.

How can I check if the delivering server is down?

--------------------------------------------------
----------SOLVED-------------------------------
--------------------------------------------------

The problem was a signature fail while updating the software list. After syncing time with browser, I run the sketch again successfully.

Now I continue with node.js installation.....

Thanks a lot for your help......

Go Up