Go Down

Topic: due condizione con un if (Read 7624 times) previous topic - next topic

doppiozero

#15
Jun 04, 2015, 08:29 pm Last Edit: Jun 04, 2015, 08:31 pm by doppiozero
hai sottomano altri led? per provare se è colpa di arduino o del led rgb

@Vespucci: penso che scrivere analogRead(0) sia equivalente a scrivere analogRead(A0)
Runtime Clock Manager -- https://github.com/duezero/RCM---Runtime-Clock-Manager
GPX datalogger -- https://github.com/duezero/GPX-datalogger
LiPo cycles counter -- https://github.com/duezero/LiPo-cycles-counter

Vespucci


doppiozero

Runtime Clock Manager -- https://github.com/duezero/RCM---Runtime-Clock-Manager
GPX datalogger -- https://github.com/duezero/GPX-datalogger
LiPo cycles counter -- https://github.com/duezero/LiPo-cycles-counter

ArduinoNovellino



se volete ho un immagine per farti capire la situazione ....

Vespucci

#19
Jun 04, 2015, 08:46 pm Last Edit: Jun 04, 2015, 08:50 pm by Vespucci
Uhm.... io rgb led non ne ho mai usati ma quei digitalwrite sei sicuro che devi metterli , perché mi sembra un controsenso se poi fai l'analogwrite ti rimangono sempre HIGH quei pin


edit: sto guardano un po in giro ma non mi sembra utilizzino digitalwrite con led rgb

ArduinoNovellino

Uhm.... io rgb led non ne ho mai usati ma quei digitalwrite sei sicuro che devi metterli , perché mi sembra un controsenso se poi fai l'analogwrite ti rimangono sempre HIGH quei pin
quindi secondo te dovrei toglierli ho semplicente mettere un analogWrite (x,0)?

Vespucci

#21
Jun 04, 2015, 08:52 pm Last Edit: Jun 04, 2015, 08:56 pm by Vespucci
Ma metti // come fossero commenti e prova

edit: per me è un controsenso... ora guardo qualche led rgb in giro e ti dico

ariedit: qui nel codice non ci sono
https://sjackm.wordpress.com/2012/03/26/visualizing-temperature-as-color-using-an-rgb-led-a-lm35-sensor-and-arduino/

ArduinoNovellino

Uhm.... io rgb led non ne ho mai usati ma quei digitalwrite sei sicuro che devi metterli , perché mi sembra un controsenso se poi fai l'analogwrite ti rimangono sempre HIGH quei pin


edit: sto guardano un po in giro ma non mi sembra utilizzino digitalwrite con led rgb
poi anche se fosse che rimangono HIGH il led RGB fa un colore (che caso vuole è quello del "freddo")

ArduinoNovellino

Ma metti // come fossero commenti e prova
gia fatto ... ma nulla

doppiozero

prova ad invertire i cavetti del led. se rimane sempre blu hai il led rotto
Runtime Clock Manager -- https://github.com/duezero/RCM---Runtime-Clock-Manager
GPX datalogger -- https://github.com/duezero/GPX-datalogger
LiPo cycles counter -- https://github.com/duezero/LiPo-cycles-counter

ArduinoNovellino

prova ad invertire i cavetti del led. se rimane sempre blu hai il led rotto
fatto cambia colore....

doppiozero

ho esaurito le idee.. son sicuro che la soluzione sarà una stupidata, ci staremo perdendo in un bicchiere d'acqua  :smiley-sweat:
Runtime Clock Manager -- https://github.com/duezero/RCM---Runtime-Clock-Manager
GPX datalogger -- https://github.com/duezero/GPX-datalogger
LiPo cycles counter -- https://github.com/duezero/LiPo-cycles-counter

ArduinoNovellino

comprerò un arduino nuovo dato che penso sia quello il problema ....
GRAZIE A TUTTI PER L'AIUTO!

Vespucci

Aspetta !! fai prima delle prove.
Prima prova dei led normali sui pin che utilizzi per l'RGB e vedi se almeno il programma funziona.
Seconda cosa e spostare i pin su altri pin pwm  tipo il 3,5 e il 6.

uwefed

1) hai messo dele resistenze sui LED?
2) Se é un LEd RGB ha il anodo o il catodo comune?
3) come hai collegato il LED RGB?

Prego una foto con piú luce dove si vedono i collegamenti dei fili.

Ciao Uwe

Go Up