Go Down

Topic: FTDI Programming Out of Sync Error (Read 1 time) previous topic - next topic

freckletoe2

Jun 18, 2015, 12:18 am Last Edit: Jun 18, 2015, 12:43 am by freckletoe2
Hi all,

I'm working on a project that's using the Atmega328 and I'm wanting to program it using an FTDI cable from Sparkfun (https://www.sparkfun.com/products/9718). I've attached the Eagle schematic that I'm using.

Anyways, the issue that I'm getting is when I turn on the option in Arduino IDE to show avrdude output, it says:
Quote
System wide configuration file is "C:\Program Files (x86)\Arduino/hardware/tools/avr/etc/avrdude.conf"

         Using Port                    : COM3
         Using Programmer              : arduino
         Overriding Baud Rate          : 119200
and then some error like "programmer not responding".



I tried using the FTDI cable to program an Uno that I have laying around and tested it first with the normal USB-B cable and that worked, but the FTDI didn't.

I had the FTDI connected to the Arduino as follows:

GND > GND
Rx > Tx (Digital Pin 1)
Tx > Rx (Digital Pin 0)
5V > 5V
CTS > GND
RTS > (0.1uF cap in series) RESET


and I get the same error as the breadboard version.

I'm definitely getting 5V on the FTDI cable because the Uno has lights on when I connect 5V and GND, but I'm not convinced that it's transmitting or receiving because I don't see the Rx or Tx lights on the Arduino flashing when I try to upload anything. So maybe the cable is bad?

In addition to that test, I tried setting up the Uno as an FTDI programmer (outlined here: http://www.instructables.com/id/Arduino-Examples-2-Use-an-Arduino-as-a-FTDI-Progr/) and that didn't work either.


I've triple checked all my COM ports, board settings, etc. are correct and after several hours of working this problem I have zero clue what my issue is. They're not present on the schematic, but I've also tried adding 1k pull-up resistors to my Tx and Rx lines, but that didn't seem to help.



Any thoughts?


Apparently the forums don't like it when you attach .SCH, so  here's a Goggle drive link


Also, the Atmega chip has the Optiboot bootloader from Sparkfun already on it.

hiduino

Looks like your boards.txt definition for this board has an incorrect baud rate setting of 119200.  If you are using the optiboot bootloader then you should have the baud rate at 115200.

freckletoe2

I don't think that's the case because the Uno has a baud rate of 115200 and that doesn't work.

Paul__B

#3
Jun 27, 2015, 06:05 am Last Edit: Jun 27, 2015, 06:11 am by Paul__B Reason: Sigh! Always more.
Did you remember to jumper pins 5 and 6 on the ICSP header near the USB connector in order to disable the built-in mega16U2 USB interface when you want to connect an external FTDI cable?

Otherwise, it will obviously prevent you from asserting the necessary signals (and particularly, reset).

And - if you are trying to "breadboard" a mega328 using either an FTDI cable or a UNO with its mega328 removed, then you realise you need to use one that has the correct bootloader for the board type you specify, and a crystal and its capacitors?

Go Up