Go Down

Topic: Problème quand le FTDI est connecté au Mini Pro (Read 640 times) previous topic - next topic

pierrot10

Jul 09, 2015, 08:05 am Last Edit: Jul 10, 2015, 09:35 pm by pierrot10
Hello!!
J'ai un problème étrange avec ma carte FTDI

Mon project consiste avec:
IArduino Mini Pro 3.3V et un Macbook Air.
un module GPS SIM968C de SIMCOM

Senario:
Mon Arduino utilise les pins 9,12,13 pour alimenter le GPS, tout particulierement le module 68.
(Le SIM968C est un borad qui comprend le SIM900 et le SIM68)
Processus d'alimentation:
http://www.hello-web.net/temp/t.png

D'abord, la pin 13 de l'aduino passe a 1, pour mettre la pin STDBN du 968C à 1. La pin TSDYBYN est mis LOW internement (pull down internaly).
40ms après, the pin 12 doit passé à 1 et est 2 transistors en saturation pour fournir du 3.3V à la pin GPS_VCC du GPS. Une diode Scjokkti fait diminuer la rension de 0.3V.
Ensuite, 50ms  après, la pin 9 passe à 1 pour mettre la pin GPS_RST à 1. (GPS_RST is pull up internaly).


Et finallement, la pin  56 du GPS, GPS_STDBYOUT,  (output), passe à 1 et allume une led.

Ce processus est lancé juste avant de sortir de la boucle setup et juste avant qu'une derniere instruction allume led juste pour avoir une indication visuel que le settup() est terminé et qu'il passe à la boucle loop()

Voici des schema pour mieux voir mon problème ou erreur
STDBYOUT:
http://www.hello-web.net/temp/GPS_STDBYOUT.png
GPS Powering:
http://www.hello-web.net/temp/GPS_VCC.png


Le problème avec la carte FTDI:
Quand je ferme mon switch pour alimenter mon circuit avec la batterie li-ion 3.7V, je devine que ca fonctionne. je n'ai pas de terminal mais je vois que les led s'llume dans le bon ordre et que la led The GPS_STDBYOUT s'allume au bon moement. Aussi, j'ai un petit bouton poussoir qui fonctionne. Donc je suis dans loop()

Mais quand je branche ma carte FTDI de mon Mac au mon Arduino mini pro 3.3V, la led GPS_STDBYOUT s'allume immédiatement et reste allumée!!.

Avez vous une idée pourquoi?

Si quelqu'un a une expérience avec le SIM968C et tout particulierement sur le processus d'allumage/alimentation, ca me serait d'une très grande aide

PS: Une batterie 2200mA est indispensable pour alimenter mon circuit, car le port USB ne suffit pas

Merci beaucoup!!
Il ne suffit pas de tout savoir, la persévérance, c'est déjà presque tout!
You can not know everything, perseverance, it is almost everything!

pierrot10

#1
Jul 10, 2015, 08:06 pm Last Edit: Jul 10, 2015, 09:36 pm by pierrot10
Bonjour,
Es-ce quelqu'un aurait une prtite idée?
Je viens de mettre à jour le poste avec des informations plus précises et des schémas.
Milles mercis
Il ne suffit pas de tout savoir, la persévérance, c'est déjà presque tout!
You can not know everything, perseverance, it is almost everything!

Go Up