Go Down

Topic: [ Tah Board ] Hanged on uploading code (Read 1 time) previous topic - next topic


site : www.tah.io

I had tried to burn code on Tah boards. But unfortunately it keeps on waiting at uploading.... If I press on reset to upload data, the Tah board occupies another port. ie. from ttyACM0 to ttyACM1. Is there any working solution for ubuntu? I am using arduino 1.6.5 IDE and selected leonardo as board selection.

I tried with Mac, it works. But not on Ubuntu.
The tah board is based on leonardo boards.


Aug 14, 2015, 10:15 pm Last Edit: Aug 14, 2015, 10:16 pm by Anwaarullah
If you've selected the Tah as a Board in the Arduino IDE, have you made sure that you've modified the Boards.txt file in the Arduino folder and added a section for Tah with the corresponding VID/PID pairs of Tah?

The Boards.txt file in Ubuntu/Debian is usually located at /usr/share/arduino/hardware/arduino/Boards.txt

Copy the description for Leonardo and replace the entries for VID and PID.

If you encounter any issues, let me know and I'll pull out the Boards.txt file from my Linux installation.


P.S: Does simply selecting the Leonardo option in the Boards menu allow you to upload via the IDE without having to reset?

Go Up