Go Down

Topic: Problems configurating Marlin I think. (Read 6760 times) previous topic - next topic

MaxBo

Hey there,
I've just finished assembling my Materia101 and tried to upload the fimware. It's uploading wthtout an error but although the LCD turns on, it is not showing anything. I guess I've have to made some changes in the Configuration.h file but I'm not sure which. Is there a list or something of the changes you have to make?
Any help would be greatly appreciated. Thx

kengdahl

More likely its an issue with the cables going to the screen.

MaxBo

Sorry for the big delay. Had some major family-issue to take care of. Finally i checked the wireing and i am pretty sure i got it right. Espacially the wireing for the display. The two flat cables that come from the display were already attached to the small pcb that goes on the RAMPS and it only fits in one place, right?
Still thinking i got some problems with Marlin. When i power the Materia101 LED-stripe lights up, bottom fans starts turning and the LCD-Display shows blocks in first and third row. Is there anyway to test the display without using Marlin?

normoldboy

MaxBO:

I hope you got your problem sorted out. The cables going from the small PCB were on connectors marked 1 and 2. You have to ensure that the cables are connected to the LCD display on the correct connector which are marked 1 and 2, also the PCB connector can go improperly with the connector marked 3 hanging off the end of the board. that connector must mate with connector 3 on the RAMPS board. See page 43 fig 1. The cables themselves are indexed so they fit into the connectors only one way.

MaxBo

@ normoldboy:

Thanks for your reply. I checked the wirering again and everything seems right. Cable 1 goes to connector 1 and cable 2 goes connector two. The connector marked three one the smaal PCB goes to the connector marked AUX3 on the RAMPS.

I saw that on the MATERIA101 product-page now there is a Marlin-version with the necessary changes already made to the configuration.h file. So I updated my Arduino IDE and loaded the new Marlin-version up.
The LCD still wont show anything but at least now i am able to get some feedback through serial monitor. There it says "echo SD init failed". Due to the fact that the SD-card reader and the LCD both are on the smart-controller I think there might be a problem with the smart-controller. Any ideas?

normoldboy

#5
Jun 02, 2015, 09:08 pm Last Edit: Jun 02, 2015, 09:17 pm by normoldboy
MaxBo:
The cables going to your LCD No. 1. actually operates the LCD, if you pull that cable off, nothing lights. No. 2. operates the vernier switch (Display Potentiometer), and if you pull that cable off, you cannot change the menu on your LCD. That in mind and since you have a lighted LCD lets assume that your LCD is just not programmed. Even with the new software and the fixed firmware, I had a problem loading the firmware. See my response to "ismaelbaum" in "Problems configuring Marlin I think"

I presumed that you used the USB port on the Arduino board, rather than the USb SD card. I do not know if you can program the firmware through the SD interface since I do not have one on my board.

I ran the software setup for Arduino and gave it the new firmware file. I then stroked load in the software. Nothing happened. I had read somewhere in researching the software that the Arduino board likes a particular speed and if it does not load with one set speed for the port, then try another speed. Also I tried several different ports, but I came back to port 3 as that seems to be the port that is activated first. and speed of 19500.

Since I was using Win 8.2, I changed the speed and port by  going into Device Manager then Ports, then click on the Arduino Mega 2560 (com3) This opens up a menu page that you can change. Since I have not used Unix/Linux for years I cannot advise on changes in the Linux if you are using that to run your software.

I kept banging away, and all at once the firmware appeared. Just another thought, There is a reset switch on the Ramps board on the right slightly down from the square capacitor. Reset the board each time you try.

normoldboy

MaxBo:

Since I just found the SD slot, see above "Exercising the X,Y,Z steppers", I have another thought. In case you left the SD card in the reader, be sure to take it out before you try to Firmware the Arduino. I do not know if the two ports are connected, but try it without the slot being in the mix.

MaxBo

@ normoldboy: there is no difference with the SD-card in or out. I am starting to think the smart controller is broken. does anybody know which pins of the mega board are connected to the display. Would be really helpfull to try if it is functional.

normoldboy

MaxBro:

You definitely are not getting any LCD input from your Arduino as the firmware is the driving factor for the LCD. Otherwise it is just a lighted dial. The firmware resides in an onboard Eprom that is programmed to output information to your LCD via the connecting cables.

 See :  https://asensar.com/docs/woodmax/0001-6_woodmax_electronics/

 Even though this is a different printer it still uses the Arduino/Ramps 4.1 arrangement to drive it. Programming the firmware is a hit and miss situation as the board is kinky to a specific programming frequency. It took me three tries to program my board, and it took at 19500. Also the Firmware must not contain any errors as that may prevent it from programming.

Take the two boards apart again as corrosion on any of the connecting pins will not allow proper reading at high frequency rates. make sure you are following the programming sequence to the letter.

kengdahl

@MaxBo

I'm starting to think you should send an email to support@sharebot.it

/K

MaxBo

Finally got it working. Feel kinda stupid about my error. Didn't push the RAMPS pins deep enough into the Mega headers.

@kengdahl:
It would probably be a good thing to have a picture of the boards from the side in the assembly manual. So one can see how deep the pins are supposed to go in, because you have to use a considerable amount of strength to push them in deep enough and I was a little afraid to break something by pushing stronger.

So far pretty amazed by the printing quality. Feels good to be printing at last.
Thanks for your replies again.

kengdahl


benvolio9mm

It would probably be a good thing to have a picture of the boards from the side in the assembly manual. So one can see how deep the pins are supposed to go in, because you have to use a considerable amount of strength to push them in deep enough and I was a little afraid to break something by pushing stronger.
I was also afraid of damaging the boards when I assembled them but just kept applying pressure until I got the right fit.

Go Up