Go Down

Topic: Grove mp3 player with ATMEGA328P (Read 1 time) previous topic - next topic

luofan

Hi!

i have some problem on playing audio file of mp3 player with Atmega328P:

Grove mp3 player is working fine with Arduino board.

However when i take out the atmega328p(use as standalone),connecting it with grove mp3 player
it is not able to function.

TX(Grove mp3 player)-->pin7(Arduino pin)       RX(Grove mp3 player)-->pin8(Arduino pin)

Crystal is already added to atmega328p.

please help, thanks!

Grumpy_Mike

Quote
However when i take out the atmega328p(use as standalone),connecting it with grove mp3 player
it is not able to function.
Please post a schematic of your not working system. It sounds like your stand alone is not working. Will it do a simple blink LED sketch?

luofan

Yes! 

the atmega328 is also connected to LCD and LED in my project  Both of them is working

only the mp3 player not working

there are 4 wires of mp3 player   vcc gnd TX RX

TX--->DIGITAL PIN 7   RX--->DIGITAL PIN 8

Isaac96

Do not PM me for help. I will delete immediately.
CONNECT THE GROUNDS!

After Tuesday, even the calendar goes W T F

luofan

@Isaac96

YES!
ground and vcc is already connected.

Grumpy_Mike


luofan

@Grumpy_Mike

i don't have the schematic diagram currently

basically my connection is base on "Crystal ball" example and then

i add a LED to arduino pin 6 ,  distance sensor to arduino pin A0(14)
grove MP3 player to arduino pin 9 and pin 10



Grumpy_Mike

You claim to have something that works using a standard arduino and then when you transfer the chip to your home made system it dosn't work. That only leaves your home made system that can be at fault.

As you can make stuff without a schematic you must be much much better than me so I can't help you. Sorry.

Go Up