Go Down

Topic: Problem with Burn Bootloader using Attinycore-Master and Attyiny85 (Read 1 time) previous topic - next topic

tractionfan

Using this particular Attiny Core (AttinyCore-Master) I get an error when trying to set the bits (in particular setting the 8mhz speed) using the ISP Tools/Burn Bootloader on an Attiny85 (also Attiny84). 

The errors I get are:
avrdude: invalid value ({bootloader.unlock_bits}) specified for immediate mode,
avrdude: read from file '{bootloader.unlock_bits}' failed.

On other Attiny Cores I do not get these errors and the speed is set, but I like the AttinyCore-Master core because it works well with some libraries I am using, and the Arduino pins are identified best.

I've tried to decipher the differences (in the platform.txt and board.txt) files but get lost in the different formats of these files in the different cores.

Help would be appreciated.


DrAzzy

You're using a version of the core that does not support version 1.6.x (it's a 1.0.x core)

There are a few 1.6.x compatible ATtiny cores. See the second link in my sig for one example - I've already adjusted it to work with 1.6.x and take advantage of the new boards menu features, for a much cleaner board menu that nonetheless offers more options. It also supports almost every ATtiny chip.
ATTinyCore and megaTinyCore for all ATtiny, DxCore for DA/DB-series! github.com/SpenceKonde
http://drazzy.com/package_drazzy.com_index.json
ATtiny breakouts, mosfets, awesome prototyping board in my store http://tindie.com/stores/DrAzzy

tractionfan

Thanks for your response.  I have tried various ATTINY cores, some of which claim 1.6.4 compatibility, but some of these assign Arduino pins to ATTINY84s in a strange pattern (easy enough to fix) but mostly do not support several of the libraries I am using, eg, LocoNet and updated EEPROM with puts and gets.

The ATTINYCore-master does support these libraries and works nicely in 1.6.4 but does not do the Burn Bootloader.  As I said before, I can't decipher where that would be set/described/enabled.

Fred Miller

Go Up