Go Down

Topic: FTDI Uploader Error: avrdude: stk500_getsync()  (Read 2665 times) previous topic - next topic

hades_bearer

Dear forum, I was wondering if anybody here could give me some more ideas...

I'm trying to use a "Deek Rodot" USB to FTDI to program my sparkfun Arduino Pro Mini 5v, 16mhz
http://www.ebay.co.uk/itm/281737030948?euid=18093c31e6464387a24e140922c7c2ab&cp=1

Wiring is as follows:

FTDI        Pro Mini
GND    -   BLK
CTS     -   GND
5v      -    Vcc
TXD   -     RXI
RXD   -     TXO
DTR   -     GRN

I'm trying to upload a blank sketch, but I get the following error during the upload:

avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x99

I've also seen 0x00, 0x04


I have selected the right port, and pro mini under boards, also selected ArduinoISP as the programmer and ATmega328 5v 16mhz as the chip.

Things I have tried or verified:

  • Correct port: COM6 appears when I plug in the USB cable and disappears when I remove it.
  • Pro mini works: successfully uploaded blink using my arduino uno as an "Arduino as ISP programmer"
  • Using only the FTDI chip with TXD and RXD jumpered together anything typed into the serial monitor is returned.
  • I have tried updating the driver for the FTDI through Computer Management on Windows 7, not sure if I have the right one though, how can I test this? I read something about a recent driver bricking FTDIs?
  • Swapping Tx-Rx & Rx-Tx to Tx-Tx & Rx-Rx
  • Removing the cable between CTS and GND
  • Programming my Uno through the ICP connector on the FTDI and ICSP connector on the UNO


Any more suggestions for how to trouble shoot this or things I can test would be greatly appreciated.

Many Thanks!



hades_bearer

I've also tried putting a sketch on the promini that prints "Hello World" over the serial connection using my Uno as an ISP Programmer

When I plug the FTDI board and the promini together I can see this output through the serial monitor. So the Tx and Rx portion of the board must work and be wired correctly...

Budvar10

Just 3 signals are needed for serial programming. Rx, Tx and DTR. Your connection seems to be correct as you described above. Whenever you program Arduino via ISP, the bootloader is removed from flash and it is needed for programming via serial. It cannot work without. So the first thing you have to do at now is to load the bootloader back via ISP.
And then try programming via serial once again.
Arduino clone with ATmega1284P   http://forum.arduino.cc/index.php?topic=277260.0

johnwasser

Pro mini works: successfully uploaded blink using my arduino uno as an "Arduino as ISP programmer"
One thing a lot of people don't know is that ONCE YOU "Upload Using Programmer" THE BOOTLOADER IS NO LONGER PRESENT.  Set up our Arduino as ISP again and burn a fresh bootloader.
Send Bitcoin tips to: 1G2qoGwMRXx8az71DVP1E81jShxtbSh5Hp
See who has no social life: https://forum.arduino.cc/index.php?action=stats :)

hades_bearer

Hey thanks very much!

Got it working! You were right, bootloader was missing... doh!

After trying so many things to diagnose the problem it's nice to have it fixed!

Poor Chinese ebay seller! After I gave up for a second time trying to find MY mistake I'd assumed the FTDI board was faulty and asked for a refund!

Cheers!

Go Up