Go Down

Topic: Mega 2650 - Bootloader defekt. (Read 4044 times) previous topic - next topic

skorpi080

Hi, wie hast du die Firmware draufbekommen?
playground.arduino.cc/PmWiki/433Mhz-Funkmodule
[Arduino IDE] Feinheiten und Tricks  forum.arduino.cc/index.php?topic=632403.0

wisbo

#16
Aug 22, 2015, 11:56 am Last Edit: Aug 22, 2015, 12:29 pm by wisbo
Nach dieser Anleitung

Grüße

Willi

ElEspanol

mit dem Link Symbol in der Buttonleiste

skorpi080

Ich hab so ein usbASP, weiß jemand wo das der J2 ist?
playground.arduino.cc/PmWiki/433Mhz-Funkmodule
[Arduino IDE] Feinheiten und Tricks  forum.arduino.cc/index.php?topic=632403.0

wisbo

mit dem Link Symbol in der Buttonleiste
Das habe ich gesucht. Ist bei  meinem PC nicht zu sehen. Jetzt sitze ich am Netbook, isses da... :o
Grüße

Willi

skorpi080

Code: [Select]
avrdude -C ../etc/avrdude.conf -c avrisp -P COM3 -b 19200 -p m8 -v

hast du es genauso ins cmd eingefügt?

Bei mir zeigt der an, avrdude entweder falsch geschrieben oder Befehl nicht gefunden
playground.arduino.cc/PmWiki/433Mhz-Funkmodule
[Arduino IDE] Feinheiten und Tricks  forum.arduino.cc/index.php?topic=632403.0

combie

#21
Aug 22, 2015, 12:48 pm Last Edit: Aug 22, 2015, 12:56 pm by combie
Ich hab so ein usbASP, weiß jemand wo das der J2 ist?
Messen!

Meine Glaskugel sagt:
JP2 dürfte der nicht bestückte sein.
Mess mal ob einer der Pins am RESET und der andere an PB2 angeschlossen ist

JP3 die Lötbrücke.
Mess mal gegen PC2
Steht wohl auf Dauerlangsam.
Dann tuts das auch mit der alten Software mit fabrikneuen AVRs


Vermutlich hast du schon die neue Software auf dem USBasp.
Erkennbar daran, dass er die Wirkung des -B Parameter des Avrdude abhandeln kann.
Alles im Glaskugelmodus.
Nix Gewähr!




Quote
Bei mir zeigt der an, avrdude entweder falsch geschrieben oder Befehl nicht gefunden
Kompletten Pfad zum avrdude mit angeben
Säge kein Sägemehl.

wisbo

Das habe ich gesucht. Ist bei  meinem PC nicht zu sehen. Jetzt sitze ich am Netbook, isses da... :o
Ist der Adblocker. Abgeschaltet, alles gut.
Grüße

Willi

skorpi080

#23
Aug 22, 2015, 01:02 pm Last Edit: Aug 22, 2015, 01:06 pm by skorpi08
C:/Program Files (x86)/Arduino/hardware/tools/avr/etc/avrdude.conf

auch dabei ist derselbe Fehler

playground.arduino.cc/PmWiki/433Mhz-Funkmodule
[Arduino IDE] Feinheiten und Tricks  forum.arduino.cc/index.php?topic=632403.0

combie

Das ist der Pfad zur conf Datei.
Wichtig! Aber nicht ursächlich für die Meldung.

Ich meinte den Pfad zur avrdude.exe
Säge kein Sägemehl.

skorpi080

Das hab ich hinbekommen, dank dem Bild in der ANLEITUNG.

Jetzt sagt der mir not in sync, nehme an wegen dem J2.
Auf der Rückseite hab ich ein Loch gefunden, was mit RST verbunden ist,daneben steht PROG.
Neben dem RST Loch sind noch 3 Löcher, bei einem steht T und bei anderem R.
Was näher am RSt Loch ist und was eine Brücke darstellen sollte, denke ich, hab ich mit Kabel verbunden aber hilft nix.
playground.arduino.cc/PmWiki/433Mhz-Funkmodule
[Arduino IDE] Feinheiten und Tricks  forum.arduino.cc/index.php?topic=632403.0

combie

Dann messe mal, ob das RESET Loch zum RESET Pin des AVR führt.
Dann kannst du da den RESET Pin des ISP Kabels deines 2ten ISP Proggers anschließen.

Quote
Jetzt sagt der mir not in sync,
Was verwendest du als ISP programmer um deinen USBasp zu beschreiben?
Einen UNO? (oder so)
Dann braucht der vermutlich noch einen fetten Kondensator von Reset zu GND damit der keinen Reset macht, wenn die Serielle geöffnet wird.
Alternativ zum Kondensator: Viele haben eine Lötbrücke, welche man aufkratzen kann.
Säge kein Sägemehl.

skorpi080

#27
Aug 22, 2015, 02:32 pm Last Edit: Aug 22, 2015, 04:05 pm by skorpi08
Ja, UNO. Auch mit Mega probiert.
220uF vom GND zu RESET beim UNO ist dran.

Hab direkt vom Atmega 48 zu RST mit Kabel drangehalten, immer dasselbe.

playground.arduino.cc/PmWiki/433Mhz-Funkmodule
[Arduino IDE] Feinheiten und Tricks  forum.arduino.cc/index.php?topic=632403.0

combie

#28
Aug 22, 2015, 04:08 pm Last Edit: Aug 22, 2015, 04:25 pm by combie
Hmmm.....

Was würde ich denn tun .....?

Ich würde mich erstmal fragen: Brauche ich das Update wirklich?

OK, mal ein "Ja" als gegeben....

Laut Foto sollten die beiden PROG Löcher auf der Rückseite der Platz für den Reset Jumper sein



1. Uno an den PC
2. ArduinoISP auf den Uno spielen
3. Kondensator dran
4. PROG Brücke auf der Rückseite des USBasp setzen
5. (pin 13,12,11) also Miso, Mosi, Clock, GND und 5V verbinden
6. pin10 des Unos mit dem RST des USBasp verbinden

Dann sollte es gehen!

Teste den (ArduinoISP)Uno mal mit einem anderen AVR......
(nicht, dass es da schon klemmt)
Säge kein Sägemehl.

skorpi080

#29
Aug 22, 2015, 04:16 pm Last Edit: Aug 22, 2015, 04:20 pm by skorpi08
Du bist mein Held :D

1. Uno an den PC
2. ArduinoISP auf den Uno spielen
3. ICSP stecker rein
4. PROG Brücke auf der Rückseite des USBasp setzen

Warum müssen die Kabel einzeln gesteckt werden und nicht ICSP?
Hat auch mit dem ICSP ausgelesen

Achso, den Punkt 2 hab ich einfach nicht gemacht, kommt davon wenn man nicht überlegt und strickt nach der Anleitung geht die Anleitung vollständig liest.
playground.arduino.cc/PmWiki/433Mhz-Funkmodule
[Arduino IDE] Feinheiten und Tricks  forum.arduino.cc/index.php?topic=632403.0

Go Up