Go Down

Topic: OpenWrt Chaos Calmer is final (Read 17933 times) previous topic - next topic

RedSnake64

For 15.05 there is a old version of batman available:

Code: [Select]
kmod-batman-adv_3.18.21+2014.4.0-1_ar71xx.ipk
batctl_2014.4.0-1_ar71xx.ipk
batmand_r1439-2_ar71xx.ipk


-> https://github.com/openwrt-routing/packages/tree/for-15.05

A new version is available in the master branch:
-> https://github.com/openwrt-routing/packages/tree/master

I can compile openwrt with the master branch. But that may take some time...

mridolfi

If it is not possible to install it in an easy way for me, the 2014 version will be enough.

Thanks

mridolfi

I have a serious problem!

I can't upload any sketch on my Yun. When I try to, it compiles the sketch and then it gives me this error:

Code: [Select]
Couldn't find a Board on the selected port. Check that you have the correct port selected.  If it is correct, try pressing the board's reset button after initiating the upload.

Indeed the board is no more available. It reappears again only after restarting the board.

Is it a known issue?

RedSnake64

How did you upload your sketch? via webpanel or arduino ide?

mridolfi


RedSnake64

The Yun firmware does not affect the ATmega.

- correct COM port?
- correct board selected in the ide?
- did you already tried another USB port?

mridolfi

I tried with a Yun with the old firmware and the problem is still there.

Apparently I am not the only one and there is no solution yet:

https://github.com/arduino/Arduino/issues/3928

maranhao

RedSnake64,

Thank you so much for this. I decided to upgrade by transferring the sysupgrade.bin to the YUN and running sysupgrade on it. Everything worked well, however; after rebooting I was unable to ssh into the YUN as root. I decided to reset the wifi thinking that perhaps this got overwritten. Doing so allowed me to connect to the same web interface used to originally setup the YUN, however; after changing the settings I am still unable to ssh into the system. Any thoughts?

Thanks!

RedSnake64

Hi maranhao,

if you upgrade from an old openwrt version please make sure you are using sysupgrade with the '-n' flag.
!!!Be careful - The '-n' flag will overwrite the complete memory!!!
For example:

Code: [Select]

sysupgrade -v -n sysupgrade.bin


If you want to upgrade over the webpanel you have to untick the "Keep settings" function. This will also delete all configuration files.

This should fix your problems  ;)

maranhao

RedSnake64,

I tried your solution, namely sysupgrade -v -n with the system already in Chaos Calmer, it didn't work. So I went back to the original OpenWRT-YUN and everything was working fine. I then reinstalled Chaos Calmer, again making sure to use the -n flag. The system boots, I'm able to connect to the Arduino WiFi network and configure the device with it's own name (greenhouse), and indicate which network to connect to and the password to use. The system reboots, but now when I try to ssh root@greenhouse.local I get the following error message "Could not resolve hostname greenhouse.local" which is the same error message I was getting earlier.

As best I can gather it is failing to connect to my network. Thoughts?

maranhao

RedSnake,

I've done more digging and have found that the Yun is connected to my home network. I'm able to ssh in by specifying the devices ip address. I've also seen that the host name is specified in /etc/config/system. I just don't know why trying to ssh in with the hostname is not working. Thoughts?

RedSnake64

#41
Feb 02, 2016, 06:14 pm Last Edit: Feb 02, 2016, 06:49 pm by RedSnake64
maranhao,

Please add 'wlan0' to dnsmasq...

/etc/config/dhcp
Code: [Select]

config dnsmasq
...
list interface 'lo,wlan0'
...


Reboot your Arduino and try to ping the hostname.
In some cases you also have to reconnect the network connection on your pc.
With default settings:
Code: [Select]

ping arduino

maranhao

RedSnake,

Sorry to keep hammering you with questions. Earlier in this thread you said you were going to work on installing Python3.5. I was wondering how it went.

I downloaded all the Python3.5 packages from https://downloads.openwrt.org/snapshots/trunk/ar71xx/generic/packages/packages/ and installed them, however; when I try to run python3 I get a "-ash: python3: not found." In /usr/bin there is also a easy_install-3.5 and pip3.5 that were installed with python3.5. These return similar not found errors when I try to run them. There is a python3.5-config that does run, but it returns "Usage: /usr/bin/python3.5-config --prefix|--exec-prefix|--includes|--libs|--cflags|--ldflags|--extension-suffix|--help|--abiflags|--configdir" and I have no idea what I should be entering for those different variables.

Also, editing /etc/config/dhcp did change the fact that the arduino's name is not registering on the network. I didn't quite understand what you meant by having to reconnect the network connection on my computer though.

Thank you for all your help.

RedSnake64

maranhao,

Please try following steps:

1. Reflash yun with the actual firmware (https://github.com/RedSnake64/openwrt-yun/releases/tag/ChaosCalmer_v1.2) - Don't forget the '-n' flag ;)
2. Connect to 'Arduino Yun-############' WLAN
3. Try to ping the hostname ('ping arduino')
You should get a response from 192.168.240.1
4.  If this works connect yun to your WLAN (over the arduino webpanel - don't change the hostname)
5. yun reboots
6. append wlan0 to list interface 'lo' (see above) and restart yun
7. Wait until yun has been restarted (white led) and connected to your wlan
8. ping yun via IP
9. If this is working reboot your pc
10. Then you should be able to ping arduino via hostname

This works for me.
If the problem still exists please post your '/etc/config/dhcp' config file.


To install python3 you have to expand your memory (https://www.arduino.cc/en/Tutorial/ExpandingYunDiskSpace) and execute following commands:

Code: [Select]

opkg update
opkg install python3



If you want to install pip execute:

Code: [Select]

cd /tmp
wget http://download.rsdev.16mb.com/OpenWrt/Scripts/installPIP.sh
chmod +x ./installPIP.sh
./installPIP.sh


This can take some time ;)
Please note that not all functions of pip are tested...

maranhao

RedSnake,

I had installed python3 the way you just outline, however; that is python3.4.3 and the Arduino site does NOT contain the dev or lib2to3 packages which I am looking for. Either way, I went ahead and removed the python3.5.0 packages I downloaded and installed both python3.4 and pip as you indicated. I was able to install (I believe so) the dev package with the command "pip3 install dev," however; I have been unable to install the lib2to3 python package I need. I have downloaded it from https://git.umms.med.umich.edu/msis-linux-rhel6/python/tree/08b83e743659a896608ff6d80cf767545f2c516d/lib/python3.4/lib2to3, but don't know how to install it. Note, "pip3 install lib2to3" fails.

Below is my dhcp config file.

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.auto'
        option localservice '1'
        list interface 'lo,wlan0'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv6 'server'
        option ra 'server'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'

Thanks!

Go Up