Go Down

Topic: arduino with matlab simulink (Read 3040 times) previous topic - next topic


guys is there anyone who tried to connect an arduino mega 2560 with matlab simulink.
I connected the board but when I tried to 'Deploy to Hardware' it is showing an error message 'The call to realtime_make_rtw_hook, during the after_make hook generated the following error:
    Could not connect to specified Arduino board.' I changed the board manually to the com port but it is still showing the same message.
Please help me....


Hi Rajeshbandla,

I would check if you don't have a problem with the board drivers.
One thing to try:
Type targetupdater at the MATLAB command prompt and follow instructions for Arduino.
I would also check if you can use the Arduino IDE to load a simple LED blink sketch. This would validate that the board is responding.
I would be good to know which MATLAB version you are using.
I hope this helps,



Mr Longtrain

I am also getting the same error with matlab. I have tried blinking program by writing the code and it works perfectly. I have also changed the COM selection port manually but still getting above error.
I am using MATLAB R2015a and arduino uno board.
Could you help me with this??

Thanks in advance.


disconnect the board , Exit completely from matlab and Simulink and reconnect the board then run matlab fresh


By the way not to steel the thread here but have you guys tried the model based design tool called "Embed for Arudino". Looks similar to simulink and its free (:)


Let me know in case someone gets to try out this ?

Tenet Technetronics

Go Up