Go Down

Topic: El Capitan - Arduino IDE serial port problems (Read 83566 times) previous topic - next topic

Arthur500

#30
Dec 27, 2015, 08:20 am Last Edit: Dec 27, 2015, 08:26 am by Arthur500
There seems to be a new SIGNED driver from the official source dated 3-Nov-2015. 
See http://kiguino.moos.io/2014/12/31/how-to-use-arduino-nano-mini-pro-with-CH340G-on-mac-osx-yosemite.html

I tried it and it works on El Capitan!!!  Need to Option-Open the package to make it run.

Also found found I needed to select some other board then reselect Nano to get the correct port options (/dev/cu.whcusbserialNNN) to show up.

ArdLab_Gent

There seems to be a new SIGNED driver from the official source dated 3-Nov-2015.  
See http://kiguino.moos.io/2014/12/31/how-to-use-arduino-nano-mini-pro-with-CH340G-on-mac-osx-yosemite.html
Works fine with El Capitan (OS X 10.11 (15A284)), IDE 1.6.5 and NodeMCU 1.0 (CH340).
Cannot test with Arduino as I have no Arduino with CH340.

Thanks for the link
ArdLab geeft Arduino workshops voor beginners.
ArdLab is lid van de STEM-Academie.
http://www.ardlab.gent - http://www.stem-academie.be/

PhilippeFromGpe

I had problems until I inserted a usb hub between my iMac (el Capitan) and my original ardunino Uno and now it's working.

Each time I tried to upload a sketch, cpu goes to 100% and I was not able to open serial monitor

Now, with the usb hub, I can open the serial monitor, compile  and upload sketches without troubles.

On the Mac console windows , the only difference is I don't see anymore  the following message :
AppleUSBHostPort::resetGated: retrying enumeration in 100 ms

I hope this will help someone
42 est la réponse

Hal_cat

I have noticed lots of action on fixing problems with the Arduino IDE, but with the latest hourly build from Jan 11, 2016, I cannot download software to a real Arduino UNO rev 3 from the IDE on a Mac running El Capitan, and when I try I lose the Bluetooth connection to my keyboard and mouse.

While I realize that this was caused by changes made by Apple, I am disappointed that no fix has been made as yet.  The problem is now several months old.

I have a very poor work around, running the IDE under a VM, so I am not out of business.

If someone tells me how to get diagnostic info I would be happy to do that.

BruceinHawaii

No luck with El Capitan for me either.  I am running Arduino IDE 1.6.7 and have a Zero board purchased from Arduino.cc.  Only port option showing up is "/dev/cu.bluetooth-incoming-port". 

fedemengo

I did.. You have to download this driver:

http://0xcf.com/2015/03/13/chinese-arduinos-with-ch340-ch341-serial-usb-chip-on-os-x-yosemite/

but you don't have to follow the instructions, these works with El Capitan, so:

  • Download the driver.
  • Install the driver, I insalled it from the pkg.
  • Reboot your mac in safe mode (Command + R while booting).
  • Open terminal and disabple System Integrity Protection:
    kext-dev-mode=1 (deprecate), it works with "csrutil disable". And reboot.
  • On startup check your SIP:
    "csrutil status", if it show Disabled you are ok otherwise back to pt 3.
  • Now this (I don't really know if it's strictly required):
    sudo ln -s /dev/tty.wch\ ch341\ USB\=\>RS232\ 1410 /dev/tty.wch


Now everything should works, at least it works for me. :D  ;)

Tayac

Hi,

I've the same problem with a fresh install of El Capitan on a Mac Mini. So I've found a workaround which is not the best solution, but it works.

On my MacI've installed Virtualbox https://www.virtualbox.org and its virtual box extension pack. Then I've installed Windows 7 on the virtual machine, the Arduino software, set up the configuration, drivers, ...
It took a long time for the completion but now I could use again the Arduino on the Mac.

Cheers

stefanomasini

I had the same problem. I found a signed version of the driver that solved the problem for me:

http://blog.sengotta.net/signed-mac-os-driver-for-winchiphead-ch340-serial-bridge/

gradybooch

No joy here. I have an out of the box official Arduino Uno R3, the latest version of the Arduino app (1.6.8 Hourly Build 2016/02/02 running on a Mac with the latest version of El Capitan), and I've selected the proper board (Arduino Uno) and serial port (in my case /dev/cu.usbmodem141111 (Arduino Uno/Genunio Uno
). I'd tried disabling SIP, but still nothing.

When uploading, I get the dreaded

    avrdude: stk500_recv(): programmer is not responding

I've been searching forums for almost two hours, and no one seems to have a solution.

Has anyone yet been successful?

kunklekid


FrktLille

#40
Mar 12, 2016, 06:10 pm Last Edit: Mar 16, 2016, 06:46 pm by FrktLille
 :)  :)

Great news ! I have found a solution that's work perfectly on Mac OS X El Capitan (10.11) !

As I my uploads worked fine on Arduino Pro Mini with my FTDI breakboard and suitable Apple Signed driver , I have tried to use it with Arduino Uno, but it didn't work ...
After long reads in forums and several try, I have finally found the solution that's work perfectly !

You have to use an FTDI breakboard (Sparkfun) in replacement of built-in Atmega USB chip.

Once you have an FTDI breakboard, download driver :
http://www.ftdichip.com/Drivers/VCP/MacOSX/FTDIUSBSerialDriver_v2_3.dmg

Step 1: Install Driver
=>Once done, and break board connected to your Mac, you will show "FT232R USB UART" in detailled system information, under USB


Step 2 : Wiring (BB = Breakboard)
BB GND to Arduino GND
BB VCC to Arduino VCC
BB TX0 to Arduino RXD
BB RXI to Arduino TXD
and the last most special wiring => BB DTR to Arduino Reset with 100nF capacitor between DTR pin and Reset pin (In my case, it didn't work, but with an additional 100nF capacitor to reach 200nF, it works fine !!)

Step 3 : Arduino IDE
Select >Tools > Port: "/dev/cu.usbserialA700e5Q6

Step4 : Upload as usual ... and have fun

Vince100

Thank you FrktLille !!

That work perfectly on mac.

RudiNiemeijer

So, even though there are success stories, a solution for the new MKR1000 ('Maker One?') for use in OS X El Capitan seems not at hand. I've tried the solution to disable the 'check for signed drivers' to no avail. Tried removing drivers, downloaded the hourly build, but no success.

Anyone here who got an Genuino (or Arduino for that matter) MKR1000 working under OS X 10.11.3 El Capitan?

Do we know what drivers (what chip brand) the MKR1000 needs? Are these signed?

damienholloway

I had trouble with OSX 10.11 and MKR1000. I connected the MKR1000 to another Macbook running 10.9 and loaded the getting started sketch. Once I did that I was able to plug the device back into my 10.11 device running EL Capitan and the port appeared. I don't understand why.

FrktLille

About MKR1000,

In my opinion, you should be able use the given solution with ftdi breakout board on MKR1000 too, using the MKR1000 following pins :
GND : 11
5V : 14
TX : 9
RX : 8
Reset : 10

Actually, I think this solution can be used on all arduino boards ...

Go Up