Go Down

Topic: [Solved] SdPlay.init doesn't work (Read 852 times) previous topic - next topic


Oct 12, 2015, 09:59 pm Last Edit: Oct 13, 2015, 11:51 am by FranTra
Hi, I'm starting using the SimpleSDAudio library and I have a problem.
I've been searching info about how to use it (for sure I've been using the offial guide in the website:

http://www.hackerspace-ffm.de/wiki/index.php?title=SimpleSDAudio )

In that web you can follow all the steps, it's really clear, however, it doesn't bring you too much info if the SD is not well initilizated.

I know that the wiring is correct and my SD or my SD module aren't broken (cause other libraries like the TMRpcm can read the card, write and open text's files, etc.)

Well, first of all I must say that I'm using the SD Module V1.2


And the sketch is the BareMinimunWithDebug wich is the example where you can follow if there's any problem in your serial monitor.

I tried to change the CS pin to the 10 one and uncomment the

// SdPlay.setSDCSPin(10);

But it still not working.

Also I tried with another SD card and the same happened.

I know that the website brings this info in case of not initialition

Your SD shield may be crap and SD communication is only possible with limited speed. Try commenting the line

SPSR |= (1 << SPI2X);

in function SD_L0_SpiSetHighSpeed(). If this doesn't help, comment out also the first line and try again. If then init works you have a bad SD card shield.

But i'm not sure how to do that, and as I said, it works with the SD library and the TMRpcm.

Thanks to everyone who can help me!  ;D 

PS: I'm using Arduino Uno Rev 3


Oct 13, 2015, 11:50 am Last Edit: Oct 13, 2015, 11:51 am by FranTra
Well, after trying all, I realised that the problem was the module so I used the SD card without it and... magic! It works.

So, my advice, don't use any SD module.

Go Up