Go Down

Topic: Cannot upload to Due (Read 3791 times) previous topic - next topic

rmerriam

I have two Dues. Neither of them will accept an upload on either the programming port or the USB port. I have the IDE v. 1.6.5 (r5) installed and the Due board information.

The ON and L LEDs are lit. I don't see any activity on the TX or RX leds near them.

The RX by the programming port flashes on one board when first powered on and the cable is plugged into the programming port.

The last line in the IDE console is:

Forcing reset using 1200bps open/close on port /dev/ttyACM2
/home/<user>/.arduino15/packages/arduino/tools/bossac/1.3a-arduino/bossac -i -d --port=ttyACM2 -U false -e -w -v -b /tmp/build1362427682969201347.tmp/TimingTest.cpp.bin -R

After that, nothing.

I tried both the bossa gui and bossash. Both hang trying to do a USB scan.

I'm running Ubuntu 14.04.

Any suggestions.

AdderD

As a test run Arduino IDE sudo to see if what is happening is a permissions issue. If so then look up online how to give your user account the proper permission to access serial devices.

rmerriam

I tried running the IDE with sudo. I also tried running bossac and bossash with sudo. All of them just hang with no messages.

PeterVH

I use 1.6.5, also on kubuntu 14.04. For me it works.
Apparently it uses another version bossac:
~/.arduino15/packages/arduino/tools/bossac/1.6-arduino/bossac
Maybe upgrade the ide?
I must add though that I have problems with the 1.6.4 version of the sam package. I can upload, but the sketch (e.g.blink) does not seem to run. No idea why. I dowgraded to 1.6.3, that fixed it.

westfw

My Due (actually an Itead "derivative" board) refuses to upload without a manual reset "near" the time of upload, and doesn't seem to start the sketch without an additional reset...  (This on the "programming" port; the native usb port didn't work either, but I haven't expended any effort to get it working, either.)

Quote
Forcing reset using 1200bps open/close
I thought that this was a "thing" only on native USB ports, and that the "programming port" ran the same basic usb/serial code as the other 16u2 chips.   Perhaps not...


westfw

Quote
I thought that [1200bps causing reset] was a "thing" only on native USB ports
(nope; it's definitely in the "firmware" for the 16u2 in the Due "package."   Not in the Uno/Mega firmware, though...)



rmerriam

I have a work around but it's weird. I'll rehash all the details.

I'm on Ubuntu 14.04 with Arduino IDE 1.6.5r5. I've got a Due board but I cannot upload programs to it. The bossa program just hangs in the IDE and also on the command line if I try it there.

I've been searching all over the web for ideas. I finally decided to try the Atmel SAM programmer to see what would happen. Maybe the boot loader / programmer / whatever was corrupted and this might fix it.

I installed it and ran it. Nothing. The little dialog just goes away when I say connect. I had the Arduino IDE running at the same time and it was on a stuck upload. The upload suddenly started running and I can see it giving percentage of upload. What??

I couldn't tell if the program was running. So I switched to the standard Blink example and went through the process again. Start the upload and then start the Atmel SAM programmer. It uploads and I get blinky, blinky, blinky.

Any thoughts?

Zemovski

I just had similar problem with Arduino Uno. The program would compile but then it won't load the sketch.

At the same time, Uno was running small program, few lines, creating digital patern on 3 LEDs, from 0 to 7, just for testing purposes.

Those 3 LEDs were connected to PWM ports 0, 1 and 2. Of course, they were grounded to the GND right next to port 13.

After atempting many times, even changing the code, I thought that I will need to purchase new Uno, since that one is not working.

But then, I realized that maybe it will help if I disconect the LED circuit from Uno. I did this by simply unplagging the ground GND.

It helped!

It was surprise, but the sketch loaded successfully.

rmerriam

My situation is both better and stranger.

I installed the IDE on a Windows XP system. It uploads sketches to the DUE without any problem.

For an unrelated reason, I created a new workspace for Eclipse for Arduino work. I'm using the plug-in for Arduino development.

I loaded the BlinkWithoutPause into Eclipse. It uploads to both the Programming and User port fine. The upload from the User port runs. The upload from Programming does not. I can see the TX/RX LEDs flashing and the verification says its good.

Any ideas?

Arduinoer137

Go to tools->board manager->serach "Due"->Install Arduino SAM boards (32 bits ARM Cortex-M3)

Go Up