Go Down

Topic: Problemas sensor MQ-138 (Read 1 time) previous topic - next topic

Picaflor

Nov 14, 2015, 07:25 am Last Edit: Nov 14, 2015, 03:25 pm by Picaflor
Buenas noches tengo problema con el MQ-138 utilizo el siguiente codigo

Code: [Select]
const int gasPin = A2; //GAS sensor output pin to Arduino analog A0 pin

void setup()
{
 Serial.begin(9600); //Initialize serial port - 9600 bps
}

void loop()
{
 Serial.println(analogRead(gasPin));
 delay(1000); // Print value every 1 sec.
}


Este es el modulo http://www.sainsmart.com/sainsmart-mq138-formaldehyde-aldehydes-gas-detection-sensor-module.html

Al encender el modulo muestra valores de 772 al ponerlo en presencia de un gas da 796 y no se activa el led del módulo creo que lo he quemado alguien me puede decir que puedo hacer para regresarlo a la vida.

El modulo del sensor trabaja con un LM393.

Muchas gracias por cualquier respuesta.

surbyte

Y como lo alimentaste?

NOTA: subiste perfectamente el código. Busca la etiqueta para enlaces tmb. 


Esta imagen durará solo 30 dias. Solo muestra el ícono de enlace.

Picaflor

#2
Nov 14, 2015, 03:26 pm Last Edit: Nov 14, 2015, 03:27 pm by Picaflor
Conectado a 5V de arduino uno.

Supuestamente la conexion la hice como de costumbre pero algo salio mal.

surbyte

Y el filamento con que lo alimentaste, no me digas que con el Arduino?
Consume mas de 800mA.

Picaflor

No entiendo a que te refieres con filamento pero la conexion la realize de la misma forma gepd me confirmo que podia usar en un tema anterior.

Quote
He utilizado los pines GND, VCC a 5V y la entrada Analógica 0 de la placa arduino me podrían decir si está bien así no necesita una resistencia o algo para que no se dañe al dejarlo funcionando un día completo.
Lo que hice porque me urge hacerlo funcionar fue extraer el sensor y probarlo sin el modulo y a funcionado muy bien en un futuro buscare como recuperar el modulo ya que es mas facil manipularlo con el.

En este si utilize esta conexion.



Gracias por tu auda surbyte y dime si necesito alguna resistencia para conectar esta clase de modulo ya que tengo el mq-2 que lo he estado utilizando de la misma forma que el mq-138.

surbyte

La hoja de datos dice que el calefactor del sensor requiere 850mW a 5V, eso me da 170mA de consumo. 
No es tanto considerando que el Regulador del Arduino puede soportarlo (500mA máxmo).
Asi que me queda pensar que no estas usando bien la resistencia de calibración.
Busca la hoja de datos del sensor y verás que la Rs debe estar entre 20k y 200k, sugieren 47K para una calibración correspondiente a una concentración de 100ppm Benzene o Alcohol concentration en aire.
Parece ser que 10k no estaría bien. Prueba lo que dice la Hoja de datos a ver si resulta.

Picaflor

Me dices que en ves de esa resistencia de 10K ohm pruebe una de 47K ohm.

Tengo otra pregunta si tengo este modulo para un sensor mq-2 necesito poner alguna resistencia?


surbyte

Este parece ser el esquema de este módulo

si miras a la salida del sensor tiene un potenciómetro de 50K
Pero no veo en tu imagen 2 presets asi que no se si lo que tu foto llama ajuste de sensibilidad es el umbral para la salida D0 es precisamente la Resistencia RL con la cual debes calibrar el sensor.
Desde ya no hace falta ponerle nada pero hay que identificar mejor los elementos. Al menos yo con la imagen no termino de entender para que sirve. Una simple prueba lo confirmará.

Picaflor

Hice las conexiones que me sugeristes muchas gracias.

Go Up