Go Down

Topic: Arduino uno upload resets board but running sketch doesn't change  (Read 1 time) previous topic - next topic

chrisjeffery

This is my first time working with an arduino so I apologise if I've missed something obvious.

I'm using a sintron-hk uno R3 (ATMEGA328P-PU)
Arduino 1.6.5 running on arch linux

Selected Arduino/Genuino Uno in Tools -> Board
Selected /dev/ttyACMO in Tools -> Port

Edit: I've tried the loopback test, and it works fine.
Edit2: I've tried this from windows and it works, something to do with linux setup.

I'm using the blink example code.
I've changed the delay values to 5000 to test as the example was already running on the board at 1000ms.

Code verifies and compiles
no error message when I upload
led on board blinks a few times quickly then continues to blink at 1000ms as before, so the uploaded code is not running.

I don't think I'm missing anything obvious, and starting to worry that the board is faulty.

johnwasser

It's unusual for the upload to appear to work but not to work.  I would try turning on verbose output during upload under Preferences.
Send Bitcoin tips to: 1G2qoGwMRXx8az71DVP1E81jShxtbSh5Hp

chrisjeffery

ahh! It doesn't seem to complete the upload. The ide is still saying 'uploading...'
it does seem to reset the board (led flashes briefly) but no more

turned on verbose ouput, can't see anything interesting in the logs.

Code: [Select]

Sketch uses 450 bytes (1%) of program storage space. Maximum is 32,256 bytes.
Global variables use 9 bytes (0%) of dynamic memory, leaving 2,039 bytes for local variables. Maximum is 2,048 bytes.
/usr/share/arduino/hardware/tools/avr/bin/avrdude -C/usr/share/arduino/hardware/tools/avr/etc/avrdude.conf -v -patmega328p -carduino -P/dev/ttyACM0 -b115200 -D -Uflash:w:/tmp/build6391192295917093286.tmp/sketch_dec06a.cpp.hex:i

avrdude: Version 6.2, compiled on Dec  2 2015 at 15:23:56
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2014 Joerg Wunsch

         System wide configuration file is "/usr/share/arduino/hardware/tools/avr/etc/avrdude.conf"
         User configuration file is "/home/chris/.avrduderc"
         User configuration file does not exist or is not a regular file, skipping

         Using Port                    : /dev/ttyACM0
         Using Programmer              : arduino
         Overriding Baud Rate          : 115200

johnwasser

A bunch of people have had IDE 1.6.x problems, including IDE crashes and bizarre compile errors, when they have an old 1.5.x/1.6.x installation.  Those problems seem to be caused by out-of-date executables that the new IDE saves outside the IDE installation directory.  Perhaps that is what is causing your particular problem.  In such cases it appears that the fix is to delete or rename the old "Arduino15" directory and re-install 1.6.x.

On Mac OS X:
/Users/(username)/Library/Arduino15

On Windows:
C:\Users\(username)\AppData\Roaming\Arduino15

On Linux:
/home/(username)/.arduino15    (a.k.a. ~/.arduino15)
Send Bitcoin tips to: 1G2qoGwMRXx8az71DVP1E81jShxtbSh5Hp

chrisjeffery

Thanks John.
1.6.5 is the first version I've installed - I've literally just started with arduinos and my first attempt is not going as hoped.

For now, I'll try this board from a different computer tomorrow and order a second different board to be safe.

chrisjeffery

I confirmed that the board is working, tested on windows and uploading was fine.

checked dmesg after failed upload and found this

[16041.230452] traps: avrdude[30358] trap divide error ip:442b32 sp:7ffd648fab80 error:0 in avrdude[400000+6a000]

Go Up