Go Down

Topic: Arduino Mega 2560 refuses to upload sketch (Read 595 times) previous topic - next topic

Huberer

Hello all,

I am pretty new in programming Arduino. I received the board from a friend to do some experiments.
Everything worked fine, suddenly arduino IDE tried to access board on Com 6 instead of Com3. I removed the drivers, loaded new Driver. Board is on com 3 back and uploading sketches worked as before,
After ~ 5 Uploads, suddenly I get this error message after compilation of code:

------------------------------------------------------------------------------------------------------------------
Der Sketch verwendet 2.578 Bytes (1%) des Programmspeicherplatzes. Das Maximum sind 253.952 Bytes.
Globale Variablen verwenden 409 Bytes (4%) des dynamischen Speichers, 7.783 Bytes für lokale Variablen verbleiben. Das Maximum sind 8.192 Bytes.

avrdude: stk500v2_setparm(): failed to set parameter 0x9e
avrdude: stk500v2_command(): unknown status 0xc8
avrdude: initialization failed, rc=-1
         Double check connections and try again, or use -F to override
         this check.

avrdude: stk500v2_command(): unknown status 0x01
avrdude: stk500v2_disable(): failed to leave programming mode
--------------------------------------------------------------------------------------------------------------
Ports are still OK, I hope someone will be able to solve the mystery

Huberer

Huberer

Hello

I think we can close this item.
It was all abaout COM ports
I completely deleted the USB-drivers for my arduino, reinstalled them, but only after a change from COM 3 to COM 6 and back to COM 3 solved the problem.
I do not know why, but everything is working finde now

Have fun

Go Up