Go Down

Topic: Wifi 101 Shield seems to be connected, but no communication is happening! (Read 1 time) previous topic - next topic



I'm using an Arduino Uno, and have connected a WiFi 101 shield to it (with some difficulty--didn't slip in nicely). I am trying to use one of the sample codes provided--the WiFi Chat Server:


The Arduino is connected to a different wifi network than my computer is, but both seem to soundly be connected (the green light next to "wifi" on the board is lit, and when I run the code it indicates that the board is connected.) The code then provides an IP address, and I tried to use that in Terminal (typing "telnet (insert-IP-address-here)", but the operation timed out and it was "Unable to connect to remote host".

Similar things happen with other programs I try to run--it seems like the board is all connected and working, but when I try to actually communicate with it I am unsuccessful.

I also could not connect it to the WEP network my computer is connected to, so I've connected the Arduino to an open network (a Karma WiFi hotspot).

I'm quite baffled--any suggestions??


Go Up