Go Down

Topic: A missing chip.h file (Read 3107 times) previous topic - next topic

jfri

I can't compile the basic startup sketch for my Arduino Due since I get this compiler error


In file included from sketch_jan17a.ino:1:0:
C:\Users\Jan Work\AppData\Roaming\Arduino15\packages\arduino\hardware\sam\1.6.5\cores\arduino/Arduino.h:42:18: fatal error: chip.h: No such file or directory
 #include <chip.h>
                  ^
compilation terminated.
Error compiling.

What is this file chip.h . It's not on my computer. I would expect all needed files to be present if I install everything correctly. I only have this problem with Due not with Uno or Mega boards. My Due board seem correctly installed and having the correct drivers.

I have IDE 1.6.5 and use Windows 10

jfri


Smicuz96

#2
Feb 02, 2016, 08:43 pm Last Edit: Feb 02, 2016, 08:51 pm by Smicuz96
Solved
How did you solve? I have the same problem.
I've already tried to completely reinstall the IDE.

kvadrug

How did you solve? I have the same problem.
I've already tried to completely reinstall the IDE.
+1 to this question.

Patrick_123


Patrick_123

#5
Apr 03, 2016, 12:59 am Last Edit: Apr 03, 2016, 01:25 am by Patrick_123
K i got it now...
I use the Visual Micro Plugin for Visual Studio 2015 and installed the Due Board over the Visual Micro Explorer/Managed Boards. It seems that somehow the installation with the Visual Micro Plugin (Version 1603.30.4) is corrupt.  Now I installed the Due Board with the Arduino IDE's Board Manager and finaly it works.
I Attached some Pictures which shows the old way in Visual Micro and the working way in Arduino IDE

ratpalak

getting the same error, how to fix it?

westfw

chip.h is part of libsam, and should be in .../hardware/sam/1.6.11/system/libsam/chip.h
(libsam is really obslete, replaced by CMSIS and/or ASF and/or START in non-Arduino environments.)
If the Arduino IDE is giving you this error, it probably means you have a remnant of an old version of the IDE around that needs to be deleted so that a fresh install can work.


Go Up