Go Down

Topic: SOLVED: unable to programm Arduino Leonardo after loading unstable programm (Read 13753 times) previous topic - next topic

hoshymann

Not sure about the difference either.
Maybe .program describes the behavior using a programmer.
I guess .program.extra_params is responsible for the right COM port.

michalmonday

Thanks a lot people, saved my board :)
Btw here's a clear wiring picture if anyone needs it for Pro Micro: https://schou.dk/linux/arduino/isp/IMG_5841.JPG

allangalicia

Check this: https://www.dfrobot.com/forum/viewtopic.php?t=216

tigger

I was having a load of problems getting a Leonado to upload. It worked on one PC but not the other.
Solution?
Bypass any USB hubs and plug into the PC USB port.
It never used to be a problem and only applied to the Leonado recently, mainly because of the increasing number of USB devices attached.
No other devices are a problem, so the Leonado must be a bit fussy.
I am going to try and work out which of the hubs is causing the problem, but I have a decent 8-port hub (Cambrionix) and some cheepo's daisy-chained off that.
On the plus side, the XBee SerialDump example suddenly came to life after many hours of faffing around.
I'm coming to the conclusion that with USB hubs - all powered incidentally - it's better to have one decent multiport hub and if you have to daisy-chain, then just use them for USB power

Go Up