Go Down

Topic: Nano clone with FT232RL FTDI  (Read 3819 times) previous topic - next topic

david_isr

i just ordered a Nano V3.0 clone with ATMEGA328P FT232RL FTDI from ebay, and i cant understand what i need to do to make it work. the seller said that the Bootloader is already installed in the module, but the laptop wont recognize it when i use the arduino software. what i need to do in order to make it work?

p.s - i tried following this video, but it didnt work (i cant see the "USB serial port" option in the driver update)
https://www.youtube.com/watch?v=noj7I4XwWbg

Koepel

Google for: ftdigate
You have a counterfeit FTDI chip and that will always give problems, one way or the other.

david_isr

And i thought that the FTDI is better than the CH340G  because its more expansive lol
so i have a dead board? there is nothing i can do?
Also what is the best clone? the CH340G one's?

Koepel

#3
Feb 03, 2016, 04:41 pm Last Edit: Feb 03, 2016, 04:43 pm by Koepel
The CH340G is a good usb-serial chip. But no usb-serial chip at all is even better.
The ATmega32U4 can connect to the USB without extra usb-serial chip. They can be found in the Leonardo and Micro boards, and on Ebay in the cheap Pro Micro clones. You can easily spot them, because they don't have a serial-usb chip and they do have a usb micro connector. They are 3 dollars on AliExpress and 4 dollars on Ebay.

They have a different way to create a com port on the computer. Perhaps you better buy an official Leonardo to start with the ATmega32U4.

Most libraries are written for the ATmega328P (as used in the Uno and Nano), not every library will work with a ATmega32U4.

There is a way to repair a broken counterfeit FTDI. It depends if you have the old FTDI drivers that changed the FTDI counterfeit chips (FTDIgate) or if you have the new drivers that injects a text (FTDIgate 2.0). If you have FTDIgate 2.0, then you only need another driver, or use linux.
After repairing, it can go wrong every time you connect it to a computer.

david_isr

i already have the UNO and i need a smaller controller for my final project in collage. the code is already written so i need a controller than have the ATmega328P , so only nano....
like i said i tried to follow the guides to fix the FTDI chip (i downloaded the older driver as shown in the video i added, but i dont have the USB serial port" option in the driver update)
 

Koepel

I don't know what you should do about the driver. In the past I have fixed my counterfeit FTDI chip on a Nano but I forgot how I did that. Perhaps I used linux to correct it.

The Arduino Pro Mini uses the ATmega328P and is smaller than the Nano, but an extra usb-serial module is needed. Those modules are on Ebay as well. A usb-serial module with the DTR signal should be used.

Another option is to use a programmer and the ICSP header. Then the usb-serial chip is not used, but with a bad FTDI, it is not possible to print something to the serial port.
The Arduino Uno can be used as programmer.

Go Up