Go Down

Topic: MKR1000 Technical Information (Read 16630 times) previous topic - next topic

ciaomanuhello

Installed the WiFi101 library and tried the SimpleWebServerWiFi example that comes with it.
I changed the ssid, password to match my wifi. Also changed the led pin from 9 in the example to PIN_LED.

It worked on the first try!

The MKR1000 seems a nice board.
Can you send me the code? my board seems to keep the wifi off :(

Code: [Select]
#include <SPI.h>
#include <WiFi.h>

char ssid[] = "yourNetwork";         // your network SSID (name)
char key[] = "yourPassword";        // your network key
int keyIndex = 0;                          // your network key Index number
int status = WL_IDLE_STATUS;      // the Wifi radio's status

void setup() {
   //Initialize serial and wait for port to open:
   Serial.begin(9600);
   while (!Serial) {
     ; // wait for serial port to connect. Needed for Leonardo only
   }

   // check for the presence of the shield:
   if (WiFi.status() == WL_NO_SHIELD) {
     Serial.println("WiFi shield not present");
     // don't continue:
     while (true);
   }

   // attempt to connect to Wifi network:
   while ( status != WL_CONNECTED) {
     Serial.print("Attempting to connect to WEP network, SSID: ");
     Serial.println(ssid);
     status = WiFi.begin(ssid, keyIndex, key);

     // wait 10 seconds for connection:
     delay(10000);
   }

   // once you are connected :
   Serial.print("You're connected to the network");
}

void loop() {
   // check the network status connection once every 10 seconds:
   delay(10000);
  Serial.println(WiFi.status());
}


it Always return: WiFi shield not present

misan

Sorry, I don't think I explained well enough, but this is what I mean:
Got it working on my MacBook Air and iMac, both running stock Mavericks. It seems as if your system is not recognising the driver of the device.

Mine is running happily, wifi working right of the bat too.

SpikeSmall

Ah, thanks for your help! I already installed the new board software/ide update, but ill keep looking around!

Ita Katz

Got mine working on Windows 8.1, so if it helps anyone:
Note that in addition to installing the board via the boards manager, you also have to install a driver. The driver is not included in the latest IDE installation (1.6.7), so you will have to download the hourly build version from here: https://www.arduino.cc/download.php?f=/arduino-nightly-windows.zip
After you unzip the file, go to device manager, and under "other devices" you will see an unknown device. Right click it and choose "update driver", choose "browse my computer..." and point it under the folder you just unzipped to "\arduino-nightly\drivers". After that your board should appear under "ports".
I think you can now delete the hourly build folder and continue using the latest 1.6.7 release.

In the library manager in the arduino IDE (sketch -> include library -> manage libraries) you can enter "mkr1000" in the search filter to see what libraries are available. I installed Wifi101 and AzureIoT, but I did not have a chance to try them yet. Next thing I plan to try is the sample described here

Hope it helps

Collie147

#19
Feb 18, 2016, 12:52 pm Last Edit: Feb 18, 2016, 12:58 pm by Collie147
Anybody have any issues with the WiFi101?  I can't get any sketch with it to work.

Tried checking the wifi firmware version with the default example and it comes back with

Quote
WiFi101 firmware check.

WiFi101 shield:

zzez

Anybody have any issues with the WiFi101?  I can't get any sketch with it to work.

Tried checking the wifi firmware version with the default example and it comes back with


It nearly drove me insane, you need the new version of the library that isn't available in the library manager yet
https://github.com/arduino-libraries/WiFi101

Collie147


jemartel

Again, thanks a lot. just received my mkr1000...now to get building my robot

jwzumwalt

#23
Feb 20, 2016, 05:55 am Last Edit: Feb 20, 2016, 06:15 am by jwzumwalt
Here is a high res picture with edge pinouts. I could not find pinout info for the 10pin dip.

Collie147

I think that an ATMEL SAM JTAG header


jemartel

I am another one of the 1000 who was selected to get an MKR1000 for my submission to the "Worlds Largest Arduino Maker Challenge" contest sponsored by Hackster.io and Microsoft. Presently my MKR1000 is showing up in device manager as an Arduino Uno on com14. I have installed proper MKR1000 libraries in Arduino IDE 1.6.7 but can upload anything without an unknown board error. Any ideas?

Collie147

You'll need to update the SAMD board in Boards Manager to 1.6.3  the latest update 1.6.4 seems to have left it out. 

jemartel

Hi, thanks. What I actually did was first to uninstall the Windows Device and Manually selected the MKR1000 Programmer Port to update the Com port. Then I uninstalled ALL the SAMD boards in Boards Manager completely, each version was removed. Each time I closed the IDE down and reopened. I then searched again for MKR1000 and reloaded 1.6.3 and after a few " New Device recognized on com ports" my MKR1000 settled down to COM port 17 and I was able to upload the "WiFiWebServer" sketch to it and view the floating analog pins in my browser. I next tried the "AP_SimpleServer" but that is selecting the IP Address : 192.168.1.1 which is my HOME Router's address....any ideas on how to manually set that IP address?

Collie147

Unfortunately you cannot change the IP address in AP mode just yet.  If you're good with the h and CPP files you could edit where it sets the IP and to set it manually (there are a few places you'll need to change it) or you could write a function to set it up according to your sketch.  If they dont get around to it soon enough I'll try my hand at it myself in a week or so. 

By the way AP simple Server shouldnt interfere with your home router IP address as the device sets itself up as a WiFi host, not connected to your wifi at all but also not connected to the internet (without some routing mods to the code and sharing on a connected device)

Collie147

#29
Feb 25, 2016, 04:30 pm Last Edit: Feb 26, 2016, 02:10 pm by Collie147
Adapted a sketch I had for an ESP8266 to use as a neopixel throwie.  I think it works better than the ESP version, its faster and has a lipo connection already made!

Do what you will with it I'm sure it needs a good bit of tidying and fixing up around the edges.  
I'll be posting it up on Hackster.io later I think.


Go Up