Go Down

Topic: [SOLUCIONADO] Reinicio de Ethenet Shield por apagado de valvula solenoide (Read 1 time) previous topic - next topic

Rafael_Indriago

Feb 18, 2016, 07:34 pm Last Edit: Feb 20, 2016, 07:45 pm by Rafael_Indriago Reason: Agregar "SOLUCIONADO" al titulo.
Hola a todos  :)

Estoy ensamblando un proyecto que lleva un shield ethernet y un modulo relee, como bien sabemos, ambos de 5 voltios, sin embargo, el relee permite cortar y permitir un voltaje de 12 voltios para una valvula solenoide, cuando he conectado todo, el pin digital se coloca en HIGH y se abre la valvula sin problemas, el detalle esta cuando se coloca en LOW para cerrar la valvula, justo en ese momento se apaga el shield ethernet y se vuelve a encender, cosa que me preocupa mucho y de hecho hace inservible mi proyecto, no se si estare conectando mal las cosas o si sera la fuente de poder, ya que alimento todo desde una fuente de poder para computadoras que proporciona voltajes de 12v y 5v, he conectado tambien 3 sensores de 5v, 2 ventiladores de 12v y hasta un servomotor de 5v, todo al mismoo tiempo y nunca tuve problemas hasta que llegue a la conexion del relee para la valvula, la fuente tiene 3 amperios en la linea de 12 voltios y 18 amperios en la linea de 5 voltios, no creo que sea por falta de potencia, espero alguno pueda ayudarme  :smiley-confuse:

Adicionalmente comento que iba a crear un tema anterior a este pero consegui esa misma pregunta en el foro y solucione el problema, el transformador integrado de la tarjeta UNO se calentaba terriblemente cuando conectaba los 12 voltios al pin vin teniendo anclado el shield ethernet, luego comprobe aca en el foro que tenia que proporcionar tambien la linea de 5 voltios en el pin de 5 voltios y funciono, el transformador dejo de calentarse, coloco esta informacion por si acaso tenga algo que ver   :smiley-wink:

efect2000

seguro que el relé te crea un interferencia con la chispa, y más si es una bobina, usa un transistor si es continua o un optotriac si es alterna

Rafael_Indriago

#2
Feb 19, 2016, 10:23 am Last Edit: Feb 19, 2016, 10:32 am by Rafael_Indriago
seguro que el relé te crea un interferencia con la chispa, y más si es una bobina, usa un transistor si es continua o un optotriac si es alterna
No tengo ni idea el relee es este: http://www.diotronic.com/imgs/ef03052.jpg

He leído algo en la red de colocar un diodo, pero ese diodo creo que ya lo trae el relee, mi problema es que no soy estudiante de electrónica sino de informática, soy buen programador, pero muy ignorante en cuanto a hardware en tan bajo nivel, precisamente compre ese modulo de relee ya listo para conectar para evitarme armar el circuito con el transistor y la resistencia y todo ese cuento, probé el relee solo sin la válvula y se abre y se cierra perfectamente sin reiniciar el Ethernet Shield, este problema ocurre es cuando el relee tiene enchufada la válvula.

efect2000

a qué tension va la carga? ¿alterna o continua?
mirate esto, no está de más tener  concimientos básicos de electronica. Puedes usar un relé de estado solido, es lo que hce un relé, pero sin chispa al desconectar la carga

surbyte

Dice al comienzo que alimenta todo con una fuente de PC. 


Antes de cambiar el RELE, coloca un diodo 1n4002 a 1n4007 el valor que encuentres en antiparalelo con la bobina.
Eso es, el catodo (Raya blanca) al positivo de 12V con que alimentas la bobina, y el Anodo al negativo de 12V de la bobina. 
Cuando conmute la bobina esto evita el rechazo que genera la bobina al cambio de tensión que tiene polaridad invertida.
Veamos si eso funciona. 
Este esquema muestra otra cosa, solo mira que el diodo va entre bornes de la bobina, olvida que el esquema muestra un rele. 

Rafael_Indriago

Dice al comienzo que alimenta todo con una fuente de PC.


Antes de cambiar el RELE, coloca un diodo 1n4002 a 1n4007 el valor que encuentres en antiparalelo con la bobina.
Eso es, el catodo (Raya blanca) al positivo de 12V con que alimentas la bobina, y el Anodo al negativo de 12V de la bobina.
Cuando conmute la bobina esto evita el rechazo que genera la bobina al cambio de tensión que tiene polaridad invertida.
Veamos si eso funciona.
Este esquema muestra otra cosa, solo mira que el diodo va entre bornes de la bobina, olvida que el esquema muestra un rele.

Totalmente efectivo, coloque el diodo y me funciono, el Ethernet Shield dejo de reiniciarse, muchas gracias surbyte, tendré que desarmar la válvula para adaptar el diodo en su interior y no se vea afuera :D

surbyte

Me da mucho gusto que se resolviera. 
Ponle SOLUCIONADO a tu título.

firius2010

Antes de cambiar el RELE, coloca un diodo 1n4002 a 1n4007 el valor que encuentres en antiparalelo con la bobina.

Hola Surbyte, quisiera hacerte una pregunta con respecto a este tema, revisando el esquema del modulo que referencia Rafael que muestro a continuacion:



Observo que este ya tenia un diodo de protección en antiparalelo es que ese diodo no funciona o ¿por que es necesario agregarle otro para los cambios de tensión?

surbyte

Porque no entendiste bien lo que el describe.
Si, el módulo relé tiene un diodo, pero el conecta una válvula a ese relé, y es ESA válvula SIN DIODO la que genera el problema. Por eso cuando se cierra el relé la bobina de la válvula tiene el camino libre a menos que pongamos un diodo en antiparalelo.

firius2010

ah! ya comprendí :D gracias Surbyte entonces en ese caso ¿la válvula funciona en DC cierto? si fuese una válvula en CA ¿la solución seria conmutar en el cruce por cero?.

También me causa curiosidad si la parte lógica esta separada de la válvula por el rele y al conmutar la válvula esta genera me imagino un arco internamente en los contactos del rele,  ¿como llega esta discontinuidad a la parte lógica?, ¿por radiación? o es que ¿al alimentar con la misma fuente el arco generado genera una baja en el voltaje de fuente?

Muchas gracias por tu paciencia :D

surbyte

en DC una bobina al ser desconectada, genera una autoinducción y ese pico de tensión puede llegar a ser muy destructivo porque puede alcanzar niveles de tensión muy altos, depende del número de espiras del tipo de núcleo, etc. 
La tensión auto inducida tiene polaridad inversa a la alimentación por eso el diodo se pone en antiparalelo porque crea un circuito de descarga en la Resistencia de bajo valor de la bobina.

En CA conmutar x cruce por cero minimiza los problemas porque tambien se producen en CA.

Go Up